Ignore:
File:
1 edited

Legend:

Unmodified
Added
Removed
  • npl/fileserver/samba/samba.SlackBuild.orig

    r80c0fb9 rc5c522c  
    11#!/bin/sh
    22
    3 # Copyright 2008, 2009, 2010, 2012, 2013, 2015, 2016, 2017  Patrick J. Volkerding, Sebeka, Minnesota, USA
     3# Copyright 2008, 2009, 2010, 2012, 2013, 2015, 2016  Patrick J. Volkerding, Sebeka, Minnesota, USA
    44# All rights reserved.
    55#
     
    2424
    2525
    26 VERSION=${VERSION:-$(echo samba-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
    27 BUILD=${BUILD:-1}
     26VERSION=${VERSION:-$(echo samba-*.tar.gz | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
     27BUILD=${BUILD:-3}
    2828
    2929if [ -e $CWD/machine.conf ]; then
     
    6868mkdir -p $TMP $PKG
    6969
     70if [ -r /usr/lib${LIBDIRSUFFIX}/libtalloc.so.? -a ! -r /var/log/packages/talloc* ]; then
     71  echo "The Samba package needs to be removed before building to ensure that"
     72  echo "talloc (and possibly other bundled libraries) are included in the build."
     73  echo
     74  echo "Removing the Samba package in 15 seconds, and then continuing with the build."
     75  sleep 15
     76  removepkg samba
     77fi
     78
    7079cd $TMP
    7180rm -rf samba-$VERSION
    72 tar xvf $CWD/samba-$VERSION.tar.?z || exit 1
     81tar xvf $CWD/samba-$VERSION.tar.gz || exit 1
    7382cd samba-$VERSION || exit 1
     83
     84# Patch to install talloc/tevent/tdb libraries and includes:
     85zcat $CWD/samba.install.talloc.tevent.tdb.diff.gz | patch -p1 --verbose || exit 1
    7486
    7587if [ ! -d source3/lib/cmdline ]; then
     
    121133  --with-ads \
    122134  --without-pam \
    123   --build=$TARGET || exit 1
     135  --build=$TARGET
    124136  # Gives errors:
    125137  #--builtin-libraries=replace,ccan \
     
    127139
    128140# -j options don't seem to work... [Yes they do!  At least try to use -j below...]
    129 JOBS=6
    130 MAXJOBS=6
     141JOBS=1
     142MAXJOBS=20
    131143export JOBS MAXJOBS
    132144make -j $MAXJOBS || make || exit 1
     
    162174chmod 644 $PKG/etc/rc.d/rc.samba.new
    163175
    164 # mv $PKG/usr/share/man $PKG/usr
    165 # gzip -9 $PKG/usr/man/man?/*.?
     176#mv $PKG/usr/share/man $PKG/usr
     177#gzip -9 $PKG/usr/man/man?/*.?
    166178
    167179find $PKG | xargs file | grep -e "executable" -e "shared object" \
     
    169181
    170182# PAM related stuff we don't use:
    171 # rm -r $PKG/usr/share/locale
     183#rm -r $PKG/usr/share/locale
    172184rm -f $PKG/usr/man/man8/pam*
    173185
    174186cp -a \
    175   COPYING* MAINTAINERS Manifest PFIF.txt README* \
    176   Read-Manifest-Now Roadmap WHATSNEW.txt docs examples \
    177   $PKG/usr/doc/samba-$VERSION || true
     187  COPYING* PFIF.txt README* \
     188  Roadmap WHATSNEW.txt docs examples \
     189  $PKG/usr/doc/samba-$VERSION
    178190# These are installed elsewhere:
    179191rm -rf $PKG/usr/doc/samba-$VERSION/docs/htmldocs \
     
    204216cd $PKG
    205217/sbin/makepkg -l y -c n $TMP/samba-$VERSION-$ARCH-$BUILD.txz
     218
Note: See TracChangeset for help on using the changeset viewer.