- File:
-
- 1 edited
Legend:
- Unmodified
- Added
- Removed
-
npl/fileserver/samba/samba.SlackBuild.orig
r80c0fb9 rc5c522c 1 1 #!/bin/sh 2 2 3 # Copyright 2008, 2009, 2010, 2012, 2013, 2015, 2016 , 2017Patrick J. Volkerding, Sebeka, Minnesota, USA3 # Copyright 2008, 2009, 2010, 2012, 2013, 2015, 2016 Patrick J. Volkerding, Sebeka, Minnesota, USA 4 4 # All rights reserved. 5 5 # … … 24 24 25 25 26 VERSION=${VERSION:-$(echo samba-*.tar. ?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}27 BUILD=${BUILD:- 1}26 VERSION=${VERSION:-$(echo samba-*.tar.gz | rev | cut -f 3- -d . | cut -f 1 -d - | rev)} 27 BUILD=${BUILD:-3} 28 28 29 29 if [ -e $CWD/machine.conf ]; then … … 68 68 mkdir -p $TMP $PKG 69 69 70 if [ -r /usr/lib${LIBDIRSUFFIX}/libtalloc.so.? -a ! -r /var/log/packages/talloc* ]; then 71 echo "The Samba package needs to be removed before building to ensure that" 72 echo "talloc (and possibly other bundled libraries) are included in the build." 73 echo 74 echo "Removing the Samba package in 15 seconds, and then continuing with the build." 75 sleep 15 76 removepkg samba 77 fi 78 70 79 cd $TMP 71 80 rm -rf samba-$VERSION 72 tar xvf $CWD/samba-$VERSION.tar. ?z || exit 181 tar xvf $CWD/samba-$VERSION.tar.gz || exit 1 73 82 cd samba-$VERSION || exit 1 83 84 # Patch to install talloc/tevent/tdb libraries and includes: 85 zcat $CWD/samba.install.talloc.tevent.tdb.diff.gz | patch -p1 --verbose || exit 1 74 86 75 87 if [ ! -d source3/lib/cmdline ]; then … … 121 133 --with-ads \ 122 134 --without-pam \ 123 --build=$TARGET || exit 1135 --build=$TARGET 124 136 # Gives errors: 125 137 #--builtin-libraries=replace,ccan \ … … 127 139 128 140 # -j options don't seem to work... [Yes they do! At least try to use -j below...] 129 JOBS= 6130 MAXJOBS= 6141 JOBS=1 142 MAXJOBS=20 131 143 export JOBS MAXJOBS 132 144 make -j $MAXJOBS || make || exit 1 … … 162 174 chmod 644 $PKG/etc/rc.d/rc.samba.new 163 175 164 # 165 # 176 #mv $PKG/usr/share/man $PKG/usr 177 #gzip -9 $PKG/usr/man/man?/*.? 166 178 167 179 find $PKG | xargs file | grep -e "executable" -e "shared object" \ … … 169 181 170 182 # PAM related stuff we don't use: 171 # 183 #rm -r $PKG/usr/share/locale 172 184 rm -f $PKG/usr/man/man8/pam* 173 185 174 186 cp -a \ 175 COPYING* MAINTAINERS ManifestPFIF.txt README* \176 R ead-Manifest-Now Roadmap WHATSNEW.txt docs examples \177 $PKG/usr/doc/samba-$VERSION || true187 COPYING* PFIF.txt README* \ 188 Roadmap WHATSNEW.txt docs examples \ 189 $PKG/usr/doc/samba-$VERSION 178 190 # These are installed elsewhere: 179 191 rm -rf $PKG/usr/doc/samba-$VERSION/docs/htmldocs \ … … 204 216 cd $PKG 205 217 /sbin/makepkg -l y -c n $TMP/samba-$VERSION-$ARCH-$BUILD.txz 218
Note: See TracChangeset
for help on using the changeset viewer.