Ignore:
File:
1 edited

Legend:

Unmodified
Added
Removed
  • npl/internetserver/ebtables/ebtables.SlackBuild

    r480e6a7 rc5c522c  
    11#!/bin/bash
    2 #
    3 # Automaticly created by importpackage v1.0
    4 # Imported from: http://mirrors.slackware.com/slackware/slackware-current/source/n/ebtables/
    5 # Created at Wed Apr 26 15:31:32 CEST 2017
     2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
     3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
     4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
     5##################################### Build dependency info:
     6
     7#Strict build-dependencies.
     8#Only use when really neccesary, this will rebuild our package if the dependencie has changed:
     9##DEP:linux
     10##DEP:linux_src
     11
     12#Loose build-dependencies.
     13#Use this to specify the packages that are required to build our package:
     14##NEED:libcairo
     15##NEED:glib
     16##NEED:gtk+
     17##NEED:glib2
     18##NEED:gtk+2
     19##NEED:xorg_lib
     20##NEED:xorg_proto
     21
     22#######Essential package info.
     23#Change these if autodetection fails.
     24
     25#Name of the Syn-3 package that we are going to create
     26NAME=`basename $0|sed 's/.SlackBuild//'`
     27
     28#Archive of the sourcefiles to unpack
     29SRC_ARC=`ls *.tar.*`
     30
     31#Version of the sourcefiles
     32VER=v2.0.8_1
     33
     34#Directory of the sourcefiles to build (after optional unpacking)
     35SRC_DIR=`echo $SRC_ARC| sed 's/\.tar\..*$//g'`
     36
     37#Architecture that the created binaries run on.
     38#Use noarch for scripts.
     39ARCH=`arch`
    640
    741
    8 ########### source original slackbuild (hopefully we dont need to modify it)
    9 CWD=`pwd`
    10 set -e
    11 source ./ebtables.SlackBuild.orig
     42########Build and create the pacakge.
     43#Uncomment the stuff that you dont want or need
     44
     45#Unpack source
     46#(uncomment if not needed)
     47syn3_unpack $SRC_ARC || exit 1
     48
     49#apply patches
     50#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
    1251
    1352
    14 ############ make syn3 packages
    15 cd $CWD
    16 for PKG in /tmp/package-*; do
    17         NAME=`echo $PKG| sed 's/.*package-//'| sed 's/-/_/g'`
     53pushd $SRC_DIR || exit 1
     54make
     55mkdir -p /tmp/pkg/etc/{rc.d/init.d,sysconfig}
     56make -j1 MANDIR=/usr/man BINDIR=/usr/bin DESTDIR=/tmp/pkg install || exit 1
     57popd
     58mv /tmp/pkg/usr/lib/ebtables/* /tmp/pkg/usr/lib/ || exit 1
     59rmdir /tmp/pkg/usr/lib/ebtables || exit 1
    1860
    19         #seperate dev-package
    20         syn3_move_dev $PKG $PKG""_dev
    21         syn3_makepkg $PKG""_dev $NAME""_dev $VERSION $ARCH || exit 1
    2261
    23         #make main package
    24         syn3_makepkg $PKG $NAME $VERSION $ARCH || exit 1
    25 done
     62#strip bins and other stuff
     63syn3_strip /tmp/pkg || exit 1
     64
     65#move development stuff and create seperate development package
     66syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
     67syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
     68
     69#make main package
     70syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
     71
     72
Note: See TracChangeset for help on using the changeset viewer.