Ignore:
File:
1 edited

Legend:

Unmodified
Added
Removed
  • npl/overig/libvmime/libvmime.SlackBuild

    r516e1e9 rc5c522c  
    11#!/bin/bash
    2 
    3 #DEP:imagemagick
    4 #NEED:cmake
    5 #DEP:boost
    6 #NEED:doxygen
    7 #DEP:gnutls
    8 #DEP:openssl
    9 #NEED:linuxdoc_tools
    10 
    11 #?BuildRequires:  inkscape
    12 
    13 set -e
     2# Download vmime patches from: http://developer.zarafa.com/download/zarafa-vmime-patches.tar.gz
    143
    154#######Essential package info.
     
    4029syn3_unpack $SRC_ARC || exit 1
    4130
    42 pushd $SRC_DIR
     31#apply patches
     32for PATCH in *.diff; do
     33    patch -p1 -d $SRC_DIR < $PATCH|| exit 1
     34done
    4335
    44 #note, use github version that has cmake files that create actual makefiles, from: https://codeload.github.com/kisli/vmime/tar.gz/v0.9.2
    45 
    46 
    47 # from https://build.opensuse.org/package/view_file/server:mail:kopano/libvmime/libvmime.spec?expand=1
    48 cf="-DVMIME_ALWAYS_GENERATE_7BIT_PARAMETER=1"
    49 cmake . \
    50         -DVMIME_SENDMAIL_PATH:STRING="/usr/sbin/sendmail" \
    51         -DVMIME_BUILD_SAMPLES:BOOL=OFF \
    52         -DVMIME_HAVE_SASL_SUPPORT:BOOL=OFF \
    53         -DVMIME_HAVE_TLS_SUPPORT:BOOL=ON \
    54         -DVMIME_BUILD_STATIC_LIBRARY:BOOL=OFF \
    55         -DCMAKE_BUILD_TYPE:STRING="RelWithDebInfo" \
    56         -DCMAKE_INSTALL_PREFIX:PATH="/usr" \
    57         -DCMAKE_CXX_FLAGS_DEBUG:STRING="-g" \
    58         -DCMAKE_CXX_FLAGS:STRING="$cf -std=gnu++11" \
    59         -DCMAKE_C_FLAGS:STRING="$cf"
    60 make -j10 VERBOSE=1
    61 make install DESTDIR=/tmp/pkg
    62 
    63 popd
    64 
    65 
    66 
    67 
     36#build and install sourcefiles
     37#./configure optiones:
     38export CONFIGURE_OPTS="--disable-sasl --disable-tls"
     39#options for all make commands:
     40export MAKE_OPTS=""
     41#skip testing:
     42#export NOTEST=1
     43#extra optiones for the make install command, use with INSTALL_BASE for example:
     44export INSTALL_OPTS=""
     45syn3_build_automake $SRC_DIR /tmp/pkg || exit 1
    6846
    6947
Note: See TracChangeset for help on using the changeset viewer.