Ignore:
File:
1 edited

Legend:

Unmodified
Added
Removed
  • npl/overig/texinfo/texinfo.SlackBuild

    ra9c55d3 rc5c522c  
    11#!/bin/bash
    2 #
    3 # Automaticly created by importpackage v1.0
    4 # Imported from: http://mirrors.slackware.com/slackware/slackware-current/source/ap/texinfo/
    5 # Created at Tue Feb  7 16:49:50 CET 2017
     2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
     3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
     4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
     5##################################### Build dependency info:
     6
     7#Strict build-dependencies.
     8#Only use when really neccesary, this will rebuild our package if the dependencie has changed:
     9##DEP:linux
     10##DEP:linux_src
     11
     12#Loose build-dependencies.
     13#Use this to specify the packages that are required to build our package:
     14##NEED:libcairo
     15##NEED:glib
     16##NEED:glib_dev
     17##NEED:gtk+
     18##NEED:gtk+_dev
     19##NEED:xorg_lib
     20##NEED:xorg_proto
     21#DEP:ncurses
     22
     23#######Essential package info.
     24#Change these if autodetection fails.
     25
     26#Name of the Syn-3 package that we are going to create
     27NAME=`basename $0|sed 's/.SlackBuild//'`
     28
     29#Archive of the sourcefiles to unpack
     30SRC_ARC=`ls *.tar.*`
     31
     32#Version of the sourcefiles
     33VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g'`
    634
    735
    8 ########### source original slackbuild (hopefully we dont need to modify it)
    9 CWD=`pwd`
    10 set -e
    11 source ./texinfo.SlackBuild.orig
     36#Directory of the sourcefiles to build (after optional unpacking)
     37#SRC_DIR=`echo $SRC_ARC| sed 's/\.tar\..*$//g'`
     38SRC_DIR=texinfo-4.8
     39
     40#Architecture that the created binaries run on.
     41#Use noarch for scripts.
     42ARCH=`arch`
    1243
    1344
    14 ############ make syn3 packages
    15 cd $CWD
    16 for PKG in /tmp/package-*; do
    17         NAME=`echo $PKG| sed 's/.*package-//'| sed 's/-/_/g'`
     45########Build and create the pacakge.
     46#Uncomment the stuff that you dont want or need
    1847
    19         #seperate dev-package
    20         syn3_move_dev $PKG $PKG""_dev
    21         syn3_makepkg $PKG""_dev $NAME""_dev $VERSION $ARCH || exit 1
     48#Unpack source
     49#(uncomment if not needed)
     50syn3_unpack $SRC_ARC || exit 1
    2251
    23         #make main package
    24         syn3_makepkg $PKG $NAME $VERSION $ARCH || exit 1
    25 done
     52#apply patches
     53#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
     54
     55#build and install sourcefiles
     56#(use one of the other syn3_build_* scripts when needed)
     57export CONFIGURE_OPTS=""
     58export MAKE_OPTS=""
     59#export NOTEST=1
     60syn3_build_automake $SRC_DIR /tmp/pkg || exit 1
     61
     62#strip bins and other stuff
     63syn3_strip /tmp/pkg || exit 1
     64
     65#move development stuff and create seperate development package
     66syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
     67syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
     68
     69#make main package
     70syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
     71
     72
Note: See TracChangeset for help on using the changeset viewer.