- File:
-
- 1 edited
Legend:
- Unmodified
- Added
- Removed
-
npl/system/openssl/openssl.SlackBuild.orig
-
Property
mode
changed from
100644
to100755
ra1525ed rc5c522c 1 #!/bin/ bash1 #!/bin/sh 2 2 3 3 # Copyright 2000 BSDi, Inc. Concord, CA, USA 4 4 # Copyright 2001, 2002 Slackware Linux, Inc. Concord, CA, USA 5 # Copyright 2005, 2006, 2007, 2008, 2009, 2010, 2011, 2012, 2013, 2014 , 2015, 2018Patrick J. Volkerding, Sebeka, MN, USA5 # Copyright 2005, 2006, 2007, 2008, 2009, 2010, 2011, 2012, 2013, 2014 Patrick J. Volkerding, Sebeka, MN, USA 6 6 # All rights reserved. 7 7 # … … 23 23 # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. 24 24 25 25 26 # Set initial variables: 26 cd $(dirname $0) ;CWD=$(pwd)27 CWD=$(pwd) 27 28 TMP=${TMP:-/tmp} 28 29 29 PKGNAM=openssl30 30 VERSION=${VERSION:-$(echo openssl-*.tar.gz | rev | cut -f 3- -d . | cut -f 1 -d - | rev)} 31 BUILD=${BUILD:- 2}31 BUILD=${BUILD:-1} 32 32 33 33 # Automatically determine the architecture we're building on: … … 46 46 NAME2=openssl-solibs-$VERSION-$ARCH-$BUILD 47 47 48 # If the variable PRINT_PACKAGE_NAME is set, then this script will report what49 # the name of the created package would be, and then exit. This information50 # could be useful to other scripts.51 if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then52 echo "${NAME1}.txz"53 echo "${NAME2}.txz"54 exit 055 fi56 57 48 # Parallel build doesn't link properly. 58 49 #NUMJOBS=${NUMJOBS:--j6} 50 NUMJOBS=-j1 59 51 60 52 # So that ls has the right field counts for parsing... … … 71 63 72 64 # Use .so.1, not .so.1.0.0: 73 sed -i "s/soname=\$\$SHLIB\$\$SHLIB_SOVER\$\$SHLIB_SUFFIX/soname=\$\$SHLIB.1/g" Makefile.shared 74 65 zcat $CWD/openssl.soname.diff.gz | patch -p1 --backup --verbose --suffix=.orig || exit 1 75 66 if [ "$ARCH" = "i586" ]; then 76 67 # Build with -march=i586 -mtune=i686: 77 sed -i "/linux-elf/s/fomit-frame-pointer/fomit-frame-pointer -march=i586 -mtune=i686/g" Configure 78 LIBDIRSUFFIX="" 79 elif [ "$ARCH" = "i686" ]; then 80 # Build with -march=i686 -mtune=i686: 81 sed -i "/linux-elf/s/fomit-frame-pointer/fomit-frame-pointer -march=i686 -mtune=i686/g" Configure 68 zcat $CWD/openssl.optsx86.diff.gz | patch -p1 --backup --verbose --suffix=.orig || exit 1 82 69 LIBDIRSUFFIX="" 83 70 elif [ "$ARCH" = "x86_64" ]; then … … 90 77 # what they were compiled against, whether or not the ABI has changed. 91 78 # 92 # So, we will use the OPENSSL_VERSION_NUMBER from openssl-1.0. 2eunless ABI79 # So, we will use the OPENSSL_VERSION_NUMBER from openssl-1.0.1c unless ABI 93 80 # breakage forces it to change. Yes, we're finally using this old trick. :) 94 sed -i "s/#define OPENSSL_VERSION_NUMBER.*/\/* Use 0x1000 205fL (1.0.2e) below to avoid pointlessly breaking the ABI *\/\n#define OPENSSL_VERSION_NUMBER 0x1000205fL/g" crypto/opensslv.h || exit 181 sed -i "s/#define OPENSSL_VERSION_NUMBER.*/\/* Use 0x1000103fL (1.0.1c) below to avoid pointlessly breaking the ABI *\/\n#define OPENSSL_VERSION_NUMBER 0x1000103fL/g" crypto/opensslv.h || exit 1 95 82 96 83 chown -R root:root . … … 111 98 # These are the known patent issues with OpenSSL: 112 99 # name # expires 113 # MDC-2: 4,908,861 2007-03-13, not included.100 # MDC-2: 4,908,861 2007-03-13, included. :-) 114 101 # IDEA: 5,214,703 2010-05-25, not included. 115 102 # RC5: 5,724,428 2015-03-03, not included. 116 #117 # Although all of the above are expired, it's still probably118 # not a good idea to include them as there are better119 # algorithms to use.120 103 121 104 ./config \ 122 105 --prefix=/usr \ 123 106 --openssldir=/etc/ssl \ 124 no-mdc2 \125 107 no-idea \ 126 108 no-rc5 \ 127 109 no-sse2 \ 128 no-ssl2 \129 no-weak-ssl-ciphers \130 110 shared 131 111 132 make $NUMJOBS depend || make depend || exit 1 133 134 make $NUMJOBS || make || exit 1 135 136 make test -j1 || exit 1 112 make $NUMJOBS depend || make -j1 depend || exit 1 113 114 make $NUMJOBS || make -j 1 || exit 1 137 115 138 116 make install INSTALL_PREFIX=$PKG1 || exit 1 … … 166 144 167 145 mv $PKG1/etc/ssl/man $PKG1/usr 168 # Fix manpage name collisions, and relink anything that linked to the old name: 169 ( cd $PKG1/usr/man/man1 170 mv passwd.1 ssl_passwd.1 171 for file in *.1 ; do 172 if [ -L $file ]; then 173 if [ "$(readlink $file)" = "passwd.1" ]; then 174 rm -f $file 175 ln -sf ssl_passwd.1 $file 176 fi 177 fi 178 done ) 179 ( cd $PKG1/usr/man/man3 180 mv rand.3 ssl_rand.3 181 for file in *.3 ; do 182 if [ -L $file ]; then 183 if [ "$(readlink $file)" = "rand.3" ]; then 184 rm -f $file 185 ln -sf ssl_rand.3 $file 186 fi 187 fi 188 done ) 189 ( cd $PKG1/usr/man/man3 190 mv err.3 ssl_err.3 191 for file in *.3 ; do 192 if [ -L $file ]; then 193 if [ "$(readlink $file)" = "err.3" ]; then 194 rm -f $file 195 ln -sf ssl_err.3 $file 196 fi 197 fi 198 done ) 199 146 ( cd $PKG1/usr/man/man1 ; mv passwd.1 ssl_passwd.1 ) 147 ( cd $PKG1/usr/man/man3 ; mv rand.3 ssl_rand.3 ) 148 ( cd $PKG1/usr/man/man3 ; mv err.3 ssl_err.3 ) 200 149 # Compress and symlink the man pages: 201 150 if [ -d $PKG1/usr/man ]; then -
Property
mode
changed from
Note: See TracChangeset
for help on using the changeset viewer.