- File:
-
- 1 edited
Legend:
- Unmodified
- Added
- Removed
-
npl/internetserver/dhcp/dhcp.SlackBuild.orig
-
Property
mode
changed from
100644
to100755
r39a3656 rebc5ae5 1 #!/bin/ bash1 #!/bin/sh 2 2 3 # Copyright 2008, 2009, 2010, 2011, 2012 , 2017, 2018, 2020, 2021Patrick J. Volkerding, Sebeka, MN, USA3 # Copyright 2008, 2009, 2010, 2011, 2012 Patrick J. Volkerding, Sebeka, MN, USA 4 4 # All rights reserved. 5 5 # … … 21 21 # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. 22 22 23 cd $(dirname $0) ; CWD=$(pwd)24 23 25 24 PKGNAM=dhcp … … 31 30 PKG_VERSION=$(echo $VERSION | tr - _) 32 31 33 NUMJOBS=${NUMJOBS:-" -j $(expr $(nproc) + 1)"}32 NUMJOBS=${NUMJOBS:-" -j7 "} 34 33 35 34 # Automatically determine the architecture we're building on: … … 43 42 fi 44 43 45 # If the variable PRINT_PACKAGE_NAME is set, then this script will report what 46 # the name of the created package would be, and then exit. This information 47 # could be useful to other scripts. 48 if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then 49 echo "$PKGNAM-$PKG_VERSION-$ARCH-$BUILD.txz" 50 exit 0 51 fi 52 44 CWD=$(pwd) 53 45 TMP=${TMP:-/tmp} 54 46 PKG=$TMP/package-dhcp 55 47 56 48 if [ "$ARCH" = "i586" ]; then 57 SLKCFLAGS="-O2 -march=i586 -mtune=i686 -fcommon"49 SLKCFLAGS="-O2 -march=i586 -mtune=i686" 58 50 LIBDIRSUFFIX="" 59 51 elif [ "$ARCH" = "s390" ]; then 60 SLKCFLAGS="-O2 -fcommon"52 SLKCFLAGS="-O2" 61 53 LIBDIRSUFFIX="" 62 54 elif [ "$ARCH" = "x86_64" ]; then 63 SLKCFLAGS="-O2 -fPIC -fcommon"55 SLKCFLAGS="-O2 -fPIC" 64 56 LIBDIRSUFFIX="64" 65 57 else 66 SLKCFLAGS="-O2 -fcommon"58 SLKCFLAGS="-O2" 67 59 LIBDIRSUFFIX="" 68 60 fi … … 79 71 find . \ 80 72 \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \ 81 -exec chmod 755 {} \ +-o \73 -exec chmod 755 {} \; -o \ 82 74 \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \ 83 -exec chmod 644 {} \+ 75 -exec chmod 644 {} \; 76 77 cat $CWD/dhcommon-getifaddrs.patch | patch -p1 || exit 1 84 78 85 79 # Add PATH setting to /sbin/dhclient-script 86 80 zcat $CWD/dhclient-script.PATH.diff.gz | patch -p1 || exit 1 81 87 82 88 83 # Fix paths in manual pages … … 108 103 --with-srv6-lease-file=/var/state/dhcp/dhcpd6.leases \ 109 104 --with-cli-lease-file=/var/state/dhcp/dhclient.leases \ 110 --with-cli6-lease-file=/var/state/dhcp/dhclient6.leases || exit 1 111 105 --with-cli6-lease-file=/var/state/dhcp/dhclient6.leases 112 106 # Default pid dir is still /var/run, so no need to declare it 113 107 … … 169 163 LICENSE README RELNOTES \ 170 164 $PKG/usr/doc/dhcp-$VERSION 171 mv $PKG/etc/dhcpd.conf $PKG/etc/dhclient.conf \172 $PKG/usr/doc/dhcp-$VERSION/examples || true 165 #mv $PKG/etc/dhcpd.conf $PKG/etc/dhclient.conf \ 166 # $PKG/usr/doc/dhcp-$VERSION/examples 173 167 174 168 # If there's a ChangeLog, installing at least part of the recent history -
Property
mode
changed from
Note: See TracChangeset
for help on using the changeset viewer.