Ignore:
File:
1 edited

Legend:

Unmodified
Added
Removed
  • npl/internetserver/dhcp/dhcp.SlackBuild.orig

    • Property mode changed from 100644 to 100755
    r39a3656 rebc5ae5  
    1 #!/bin/bash
     1#!/bin/sh
    22
    3 # Copyright 2008, 2009, 2010, 2011, 2012, 2017, 2018, 2020, 2021  Patrick J. Volkerding, Sebeka, MN, USA
     3# Copyright 2008, 2009, 2010, 2011, 2012  Patrick J. Volkerding, Sebeka, MN, USA
    44# All rights reserved.
    55#
     
    2121#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
    2222
    23 cd $(dirname $0) ; CWD=$(pwd)
    2423
    2524PKGNAM=dhcp
     
    3130PKG_VERSION=$(echo $VERSION | tr - _)
    3231
    33 NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
     32NUMJOBS=${NUMJOBS:-" -j7 "}
    3433
    3534# Automatically determine the architecture we're building on:
     
    4342fi
    4443
    45 # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
    46 # the name of the created package would be, and then exit. This information
    47 # could be useful to other scripts.
    48 if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
    49   echo "$PKGNAM-$PKG_VERSION-$ARCH-$BUILD.txz"
    50   exit 0
    51 fi
    52 
     44CWD=$(pwd)
    5345TMP=${TMP:-/tmp}
    5446PKG=$TMP/package-dhcp
    5547
    5648if [ "$ARCH" = "i586" ]; then
    57   SLKCFLAGS="-O2 -march=i586 -mtune=i686 -fcommon"
     49  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
    5850  LIBDIRSUFFIX=""
    5951elif [ "$ARCH" = "s390" ]; then
    60   SLKCFLAGS="-O2 -fcommon"
     52  SLKCFLAGS="-O2"
    6153  LIBDIRSUFFIX=""
    6254elif [ "$ARCH" = "x86_64" ]; then
    63   SLKCFLAGS="-O2 -fPIC -fcommon"
     55  SLKCFLAGS="-O2 -fPIC"
    6456  LIBDIRSUFFIX="64"
    6557else
    66   SLKCFLAGS="-O2 -fcommon"
     58  SLKCFLAGS="-O2"
    6759  LIBDIRSUFFIX=""
    6860fi
     
    7971find . \
    8072  \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
    81   -exec chmod 755 {} \+ -o \
     73  -exec chmod 755 {} \; -o \
    8274  \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
    83   -exec chmod 644 {} \+
     75  -exec chmod 644 {} \;
     76
     77cat $CWD/dhcommon-getifaddrs.patch | patch -p1 || exit 1
    8478
    8579# Add PATH setting to /sbin/dhclient-script
    8680zcat $CWD/dhclient-script.PATH.diff.gz | patch -p1 || exit 1
     81
    8782
    8883# Fix paths in manual pages
     
    108103  --with-srv6-lease-file=/var/state/dhcp/dhcpd6.leases \
    109104  --with-cli-lease-file=/var/state/dhcp/dhclient.leases \
    110   --with-cli6-lease-file=/var/state/dhcp/dhclient6.leases || exit 1
    111 
     105  --with-cli6-lease-file=/var/state/dhcp/dhclient6.leases
    112106# Default pid dir is still /var/run, so no need to declare it
    113107
     
    169163  LICENSE README RELNOTES \
    170164  $PKG/usr/doc/dhcp-$VERSION
    171 mv $PKG/etc/dhcpd.conf $PKG/etc/dhclient.conf \
    172   $PKG/usr/doc/dhcp-$VERSION/examples || true
     165#mv $PKG/etc/dhcpd.conf $PKG/etc/dhclient.conf \
     166#  $PKG/usr/doc/dhcp-$VERSION/examples
    173167
    174168# If there's a ChangeLog, installing at least part of the recent history
Note: See TracChangeset for help on using the changeset viewer.