source: npl/fileserver/samba/samba.SlackBuild @ fdfd619

perl-5.22
Last change on this file since fdfd619 was 80c0fb9, checked in by Edwin Eefting <edwin@datux.nl>, 7 years ago

samba upgrade to 4.7.6

  • Property mode set to 100755
File size: 966 bytes
Line 
1#!/bin/bash
2
3# Automaticly created by importpackage v1.0
4# Imported from: https://mirrors.slackware.com/slackware/slackware-current/source/n/samba/
5# Created at Wed Mar 14 11:38:43 CET 2018
6
7#DEP:gnutls
8#DEP:nettle
9#DEP:libidn
10#DEP:p11_kit
11
12
13#DEP:cups
14#DEP:openldap
15#DEP:openssl
16#DEP:Linux_PAM
17#DEP:shadow
18#DEP:pam_ldap
19#DEP:nss_ldap
20#DEP:xfsprogs
21#DEP:acl
22#DEP:attr
23#DEP:mit_kerberos
24#DEP:python
25#DEP:popt
26
27
28########### source original slackbuild (hopefully we dont need to modify it)
29CWD=`pwd`
30set -e
31source ./samba.SlackBuild.orig
32
33#config files in seperate package
34rm -rf /tmp/package-*/etc  || exit 1
35
36############ make syn3 packages
37cd $CWD
38for PKG in /tmp/package-*; do
39        NAME=`echo $PKG| sed 's/.*package-//'| sed 's/-/_/'`
40
41        #seperate dev-package
42        syn3_move_dev $PKG $PKG""_dev
43        syn3_makepkg $PKG""_dev $NAME""_dev $VERSION $ARCH || exit 1
44
45        #make main package
46        syn3_makepkg $PKG $NAME $VERSION $ARCH || exit 1
47done
Note: See TracBrowser for help on using the repository browser.