source: npl/internetserver/libreswan/libreswan.SlackBuild @ f54b72d

gcc484ntopperl-5.22
Last change on this file since f54b72d was 60c2b1d, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

upgrade to 3.19. fixes issues with new rsakeys

  • Property mode set to 100755
File size: 1.0 KB
Line 
1#!/bin/bash
2#NEED:linuxdoc_tools
3#DEP:mozilla_nss
4#DEP:gmp
5#DEP:unbound
6#DEP:libcap_ng
7#DEP:curl
8#DEP:libevent
9#DEP:sqlite
10#DEP:Linux_PAM
11
12KVER=`uname -r` || exit 1
13NAME=libreswan
14VERSION=3.19
15CWD=`pwd`
16TMP="/tmp"
17PKGTMP="$TMP/pkgtmp"
18mkdir $PKGTMP &>/dev/null
19
20echo "* uutpakn"
21cd $TMP || exit 1
22tar zxf $CWD/$NAME-$VERSION.tar.gz || exit 1
23
24echo "* patches"
25#cd $TMP/$NAME-$VERSION || exit 1
26#patch -p1 < $CWD/klips.patch || exit 1
27
28echo "* libreswan maken"
29export CFLAGS="-w"
30
31cd $TMP/$NAME-$VERSION || exit 1
32#cd $CWD/openswan-2 || exit 1 #cvs version
33#make KERNELSRC=/usr/src/linux INC_USRLOCAL=/usr module || exit 1
34
35make USE_SYSTEMD_WATCHDOG=false INC_USRLOCAL=/usr programs || exit 1
36make USE_SYSTEMD_WATCHDOG=false INC_USRLOCAL=/usr DESTDIR=$PKGTMP install || exit 1
37#make programs || exit 1
38#make DESTDIR=$PKGTMP install || exit 1
39
40#config nu in libreswan_conf
41rm -rf $PKGTMP/etc
42rm $PKGTMP/ipsec.service
43
44
45echo "* packagen"
46cd $PKGTMP
47makepkg -l y -c n $CWD/$NAME.pkg
48echo $VERSION > $CWD/$NAME.version &&
49arch > $CWD/$NAME.arch
Note: See TracBrowser for help on using the repository browser.