Last change
on this file since 105afb5 was
1ebb340,
checked in by Edwin Eefting <edwin@datux.nl>, 4 years ago
|
kernel 5.10
|
-
Property mode set to
100755
|
File size:
581 bytes
|
Line | |
---|
1 | #!/bin/sh |
---|
2 | #DEP:linux_src |
---|
3 | #DEP:linux_headers |
---|
4 | #DEP:linux |
---|
5 | |
---|
6 | CWD=`pwd` |
---|
7 | TMP=/$CWD/tmp |
---|
8 | PKG=/tmp/pkg |
---|
9 | mkdir -p $PKG |
---|
10 | mkdir $TMP |
---|
11 | |
---|
12 | VERSION=2.16.11 |
---|
13 | |
---|
14 | ARCH=${ARCH:-i486} |
---|
15 | |
---|
16 | cd $TMP |
---|
17 | tar -xzf $CWD/i40e-$VERSION.tar.gz || exit 1 |
---|
18 | cd i40e-$VERSION/src || exit 1 |
---|
19 | |
---|
20 | make || exit 1 |
---|
21 | #make INSTALL_MOD_PATH=/tmp/pkg install || exit 1 |
---|
22 | mkdir -p /tmp/pkg/lib/modules/`uname -r`/extra || exit 1 |
---|
23 | cp *ko /tmp/pkg/lib/modules/`uname -r`/extra || exit 1 |
---|
24 | |
---|
25 | #package maken |
---|
26 | cd $PKG |
---|
27 | NAME=`echo $0|cut -f2 -d'.'` |
---|
28 | makepkg -l y -c n $CWD/$NAME.pkg > /dev/null && |
---|
29 | echo $VERSION > $CWD/$NAME.version && |
---|
30 | arch > $CWD/$NAME.arch |
---|
Note: See
TracBrowser
for help on using the repository browser.