source: npl/kernel/drv_i40e/drv_i40e.SlackBuild @ 7c410f9

Last change on this file since 7c410f9 was 1ebb340, checked in by Edwin Eefting <edwin@datux.nl>, 4 years ago

kernel 5.10

  • Property mode set to 100755
File size: 581 bytes
Line 
1#!/bin/sh
2#DEP:linux_src
3#DEP:linux_headers
4#DEP:linux
5
6CWD=`pwd`
7TMP=/$CWD/tmp
8PKG=/tmp/pkg
9mkdir -p $PKG
10mkdir $TMP
11
12VERSION=2.16.11
13
14ARCH=${ARCH:-i486}
15
16cd $TMP
17tar -xzf $CWD/i40e-$VERSION.tar.gz || exit 1
18cd i40e-$VERSION/src || exit 1
19
20make || exit 1
21#make INSTALL_MOD_PATH=/tmp/pkg install || exit 1
22mkdir -p /tmp/pkg/lib/modules/`uname -r`/extra || exit 1
23cp *ko /tmp/pkg/lib/modules/`uname -r`/extra || exit 1
24
25#package maken
26cd $PKG
27NAME=`echo $0|cut -f2 -d'.'`
28makepkg -l y -c n $CWD/$NAME.pkg > /dev/null &&
29echo $VERSION > $CWD/$NAME.version &&
30arch > $CWD/$NAME.arch
Note: See TracBrowser for help on using the repository browser.