source: npl/kernel/drv_mISDN2/drv_mISDN2.SlackBuild.disabled @ 0105685

gcc484ntopperl-5.22
Last change on this file since 0105685 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 899 bytes
Line 
1#!/bin/bash
2#DEP:linux_src
3#DEP:linux
4
5NAME=drv_mISDN2
6CWD=`pwd`
7VER=2_291109
8PKGTMP=/tmp/pkgtmp
9
10mkdir -p $PKGTMP/etc/postinst.d
11cp $CWD/post.mISDN $PKGTMP/etc/postinst.d || exit 1
12chmod +x $PKGTMP/etc/postinst.d/* || exit 1
13
14mkdir -p $PKGTMP/etc/boot.d || exit 1
15cp misdn.boot.d $PKGTMP/etc/boot.d/misdn || exit 1
16
17
18tar -xzf mISDN-$VER.tar.gz || exit 1
19
20
21cd mISDN || exit 1
22make -j1 force || exit 1
23make -j1  || exit 1
24#HACK: omdat dit in het buildscript anders word aangeroepen.
25#depmod gaat niet goed ivm verschil tussen buildroot kernel versie en echte
26rm `which depmod`
27make -j1 INSTALL_PREFIX=$PKGTMP install || exit 1
28
29pushd $PKGTMP/lib/modules/`uname -r`/extra/ || exit 1
30#strippen, omdat driver anders vele megabytes word!
31strip --strip-unneeded *
32popd
33
34
35
36
37cd "$PKGTMP" || exit 1
38makepkg -l n -c n $CWD/$NAME.pkg > /dev/null &&
39echo $VER > $CWD/$NAME.version &&
40arch > $CWD/$NAME.arch
41
Note: See TracBrowser for help on using the repository browser.