gcc484ntopperl-5.22
Last change
on this file since 0105685 was
c5c522c,
checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago
|
initial commit, transferred from cleaned syn3 svn tree
|
-
Property mode set to
100755
|
File size:
899 bytes
|
Line | |
---|
1 | #!/bin/bash |
---|
2 | #DEP:linux_src |
---|
3 | #DEP:linux |
---|
4 | |
---|
5 | NAME=drv_mISDN2 |
---|
6 | CWD=`pwd` |
---|
7 | VER=2_291109 |
---|
8 | PKGTMP=/tmp/pkgtmp |
---|
9 | |
---|
10 | mkdir -p $PKGTMP/etc/postinst.d |
---|
11 | cp $CWD/post.mISDN $PKGTMP/etc/postinst.d || exit 1 |
---|
12 | chmod +x $PKGTMP/etc/postinst.d/* || exit 1 |
---|
13 | |
---|
14 | mkdir -p $PKGTMP/etc/boot.d || exit 1 |
---|
15 | cp misdn.boot.d $PKGTMP/etc/boot.d/misdn || exit 1 |
---|
16 | |
---|
17 | |
---|
18 | tar -xzf mISDN-$VER.tar.gz || exit 1 |
---|
19 | |
---|
20 | |
---|
21 | cd mISDN || exit 1 |
---|
22 | make -j1 force || exit 1 |
---|
23 | make -j1 || exit 1 |
---|
24 | #HACK: omdat dit in het buildscript anders word aangeroepen. |
---|
25 | #depmod gaat niet goed ivm verschil tussen buildroot kernel versie en echte |
---|
26 | rm `which depmod` |
---|
27 | make -j1 INSTALL_PREFIX=$PKGTMP install || exit 1 |
---|
28 | |
---|
29 | pushd $PKGTMP/lib/modules/`uname -r`/extra/ || exit 1 |
---|
30 | #strippen, omdat driver anders vele megabytes word! |
---|
31 | strip --strip-unneeded * |
---|
32 | popd |
---|
33 | |
---|
34 | |
---|
35 | |
---|
36 | |
---|
37 | cd "$PKGTMP" || exit 1 |
---|
38 | makepkg -l n -c n $CWD/$NAME.pkg > /dev/null && |
---|
39 | echo $VER > $CWD/$NAME.version && |
---|
40 | arch > $CWD/$NAME.arch |
---|
41 | |
---|
Note: See
TracBrowser
for help on using the repository browser.