gcc484ntopperl-5.22
Last change
on this file since 0105685 was
c5c522c,
checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago
|
initial commit, transferred from cleaned syn3 svn tree
|
-
Property mode set to
100755
|
File size:
599 bytes
|
Line | |
---|
1 | #!/bin/bash |
---|
2 | #Moet toch dep zijn, om problemen te voorkomen |
---|
3 | #DEP:linux_src |
---|
4 | |
---|
5 | |
---|
6 | CWD=`pwd` |
---|
7 | NAME=linux_headers |
---|
8 | VERSION=`uname -r` || exit 1 |
---|
9 | |
---|
10 | PKGTMP="/tmp/pkg" |
---|
11 | rm -r $PKGTMP &>/dev/null |
---|
12 | |
---|
13 | cd /usr/src/linux || exit 1 |
---|
14 | #We gebruiken vanaf nu de 'officiele' manier van kernel headers exporteren: |
---|
15 | make headers_install || exit 1 |
---|
16 | mkdir -p $PKGTMP/usr || exit 1 |
---|
17 | mv usr/include $PKGTMP/usr || exit 1 |
---|
18 | |
---|
19 | #################### maak er een nette package van |
---|
20 | cd $PKGTMP || exit 1 |
---|
21 | /sbin/makepkg -l y -c n $CWD/$NAME.pkg > /dev/null || exit 1 |
---|
22 | echo $VERSION > $CWD/$NAME.version && |
---|
23 | arch > $CWD/$NAME.arch |
---|
24 | cd .. |
---|
25 | rm -r $PKGTMP |
---|
Note: See
TracBrowser
for help on using the repository browser.