source: npl/mailserver/clamav/clamav.SlackBuild @ 8ac1bcd

perl-5.22
Last change on this file since 8ac1bcd was 8b3c2d2, checked in by Edwin Eefting <edwin@datux.nl>, 7 years ago

update

  • Property mode set to 100755
File size: 1.6 KB
Line 
1#!/bin/bash
2#DEP:check
3#DEP:openssl
4#DEP:bzip2
5#DEP:zlib
6##DEP:llvm
7
8
9CWD=`pwd`;
10rm -r pkgtmp
11mkdir pkgtmp
12cd pkgtmp
13PKGROOT=`pwd`;
14cd ..
15
16#clamav
17VERSION=0.100.2
18AV=clamav-$VERSION
19tar -xzf $AV.tar.gz  || exit 1
20cd $AV  || exit 1
21./configure --enable-check --enable-llvm --with-user=amavis --with-group=avamis --disable-clamav --prefix=/usr --sysconfdir=/etc --localstatedir=/var --with-system-llvm=no || exit 1
22make   || exit 1
23export HOME=/root
24make check || exit 1
25make prefix=$PKGROOT/usr install 2>/dev/null
26syn3_strip $PKGROOT || exit 1
27cd ..
28
29#post install scripts                                                                                                                                                                                                                                                 
30chmod +x $CWD/post.*                                                                                                                                                                                                                                                   
31mkdir -p $PKGROOT/etc/postinst.d                                                                                                                                                                                                                                       
32cp $CWD/post.* $PKGROOT/etc/postinst.d
33
34#move development stuff and create seperate development package
35mkdir /tmp/pkgdev
36syn3_move_dev $PKGROOT /tmp/pkgdev || exit 1
37syn3_makepkg /tmp/pkgdev clamav_dev $VERSION `arch` || exit 1
38
39#make main package
40syn3_makepkg $PKGROOT clamav $VERSION `arch` || exit 1
41
Note: See TracBrowser for help on using the repository browser.