source: npl/overig/bzr/bzr.SlackBuild @ 0105685

gcc484ntopperl-5.22
Last change on this file since 0105685 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 1.3 KB
Line 
1#!/bin/bash
2# Generic python build script. (C)DatuX
3# Put in in a builddirectory with a python tarfile that contains a setup.py.
4# Please python_modulename for python modules.
5
6#DEP:python
7#DEP:python_setuptools
8
9#######Essential package info.
10#Change these if autodetection fails.
11
12#Name of the Syn-3 package that we are going to create
13NAME=`basename $0|sed 's/.SlackBuild//'`
14
15
16#Archive of the sourcefiles to unpack
17SRC_ARC=`ls *.tar.*`
18
19#Version of the sourcefiles
20VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g'`
21
22#Directory of the sourcefiles to build (after optional unpacking)
23SRC_DIR=`echo $SRC_ARC| sed 's/\.tar\..*$//g'`
24
25#Architecture that the created binaries run on.
26#Use noarch for scripts.
27ARCH=`uname -m`
28
29
30########Build and create the pacakge.
31#Uncomment the stuff that you dont want or need
32
33#Unpack source
34#(uncomment if not needed)
35syn3_unpack $SRC_ARC || exit 1
36
37#apply patches
38#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
39
40pushd $SRC_DIR || exit 1
41python setup.py install --root=/tmp/pkg || exit 1
42popd
43
44#strip bins and other stuff
45syn3_strip /tmp/pkg || exit 1
46
47#move development stuff and create seperate development package
48syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
49syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
50
51#make main package
52syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
53
54
Note: See TracBrowser for help on using the repository browser.