source: npl/overig/libnewt/libnewt.SlackBuild @ 0105685

gcc484ntopperl-5.22
Last change on this file since 0105685 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 2.7 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6#DEP:libslang
7#DEP:libslang_dev
8#Strict build-dependencies
9#Our package will be automaticly rebuilded if there is a major change in a DEP package.
10#(this is recommended for most dependencys)
11##DEP:linux
12##DEP:linux_src
13##DEP:openldap
14
15#Loose build-dependencies
16#The package will be installed in the buildroot during buidling, but no automatic rebuild will occur.
17#(not recommended)
18##NEED:doxygen
19#DEP:popt
20#DEP:python
21
22#######Essential package info.
23#Change these if autodetection fails.
24
25#Name of the Syn-3 package that we are going to create
26NAME=`basename $0|sed 's/.SlackBuild//'`
27
28#Archive of the sourcefiles to unpack
29SRC_ARC=`ls *.tar.* *.zip 2>/dev/null`
30
31#Version of the sourcefiles
32VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'`
33
34#Architecture that the created binaries run on.
35#Use noarch for scripts.
36ARCH=`uname -m`
37
38#from this point on, exit on errors:
39set -e
40
41########Build and create the pacakge.
42#Uncomment the stuff that you dont want or need
43
44#Unpack source
45#(uncomment if not needed)
46syn3_unpack $SRC_ARC
47
48#Directory where the sourcefiles are unpacked.
49#(you might have to adjust this if autodetection fails)
50SRC_DIR=`ls -c|head -1`
51
52#apply patches
53#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
54
55pushd $SRC_DIR
56
57#AUTOMAKE: Configure
58#Some usefull stuff you sometimes need to set:
59#export LDFLAGS="-L/usr/X11/lib/ -L/usr/lib/mysql/"
60#export LD_LIBRARY_PATH=/usr/lib/mysql
61#export VPATH=$LD_LIBRARY_PATH
62MAKE_OPTS=""
63./configure --prefix=/usr  || exit 1
64
65#AUTOMAKE: Compile
66make $MAKE_OPTS || exit 1
67
68#AUTOMAKE: Test (optional)
69if grep ^test: Makefile; then
70        make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
71        make $MAKE_OPTS test || exit 1
72elif grep ^check: Makefile; then
73        make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
74        make $MAKE_OPTS check || exit 1
75fi
76
77#AUTOMAKE: Install
78mkdir -p /tmp/pkg &>/dev/null
79make pkgconfigdir=/usr/lib/pkgconfig install_prefix=/tmp/pkg instroot=/tmp/pkg DESTDIR=/tmp/pkg INSTALL_ROOT=/tmp/pkg install_root=/tmp/pkg $MAKE_OPTS install || exit 1
80popd
81
82#strip bins and other stuff
83syn3_strip /tmp/pkg || exit 1
84
85#move development stuff and create seperate development package
86syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
87syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
88
89#make main package
90syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
91
92
93
Note: See TracBrowser for help on using the repository browser.