source: npl/overig/liboauth/liboauth.SlackBuild @ 0105685

gcc484ntopperl-5.22
Last change on this file since 0105685 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 2.4 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6
7
8#######Essential package info.
9#Change these if autodetection fails.
10
11#Name of the Syn-3 package that we are going to create
12NAME=`basename $0|sed 's/.SlackBuild//'`
13
14#Archive of the sourcefiles to unpack
15SRC_ARC=`ls *.tar.* *.zip 2>/dev/null`
16
17#Version of the sourcefiles
18VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'`
19
20#Architecture that the created binaries run on.
21#Use noarch for scripts.
22ARCH=`uname -m`
23
24#from this point on, exit on errors:
25set -e
26
27########Build and create the pacakge.
28#Uncomment the stuff that you dont want or need
29
30#Unpack source
31#(uncomment if not needed)
32syn3_unpack $SRC_ARC
33
34#Directory where the sourcefiles are unpacked.
35#(you might have to adjust this if autodetection fails)
36SRC_DIR=`ls -c|head -1`
37
38#apply patches
39#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
40
41pushd $SRC_DIR
42
43#AUTOMAKE: Configure
44#Some usefull stuff you sometimes need to set:
45#export LDFLAGS="-L/usr/X11/lib/ -L/usr/lib/mysql/"
46#export LD_LIBRARY_PATH=/usr/lib/mysql
47#export VPATH=$LD_LIBRARY_PATH
48#export CFLAGS="-std=c89"
49#export CFLAGS="-fgnu89-inline" #If "multiple definition of `foo'" Also see http://gcc.gnu.org/gcc-4.3/porting_to.html
50MAKE_OPTS=""
51./configure --prefix=/usr --disable-libcurl --disable-curl || exit 1
52
53#AUTOMAKE: Compile
54make $MAKE_OPTS || exit 1
55
56#AUTOMAKE: Test (optional)
57if grep ^test: Makefile; then
58        make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
59        make $MAKE_OPTS test || exit 1
60elif grep ^check: Makefile; then
61        make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
62        make $MAKE_OPTS check || exit 1
63fi
64
65#AUTOMAKE: Install
66mkdir -p /tmp/pkg &>/dev/null
67make pkgconfigdir=/usr/lib/pkgconfig install_prefix=/tmp/pkg DESTDIR=/tmp/pkg INSTALL_ROOT=/tmp/pkg install_root=/tmp/pkg $MAKE_OPTS install || exit 1
68popd
69
70#strip bins and other stuff
71syn3_strip /tmp/pkg || exit 1
72
73#move development stuff and create seperate development package
74syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
75syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
76
77#make main package
78syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
79
80
81
Note: See TracBrowser for help on using the repository browser.