source: npl/overig/libvmime/libvmime.SlackBuild @ 0105685

gcc484ntopperl-5.22
Last change on this file since 0105685 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 1.6 KB
Line 
1#!/bin/bash
2# Download vmime patches from: http://developer.zarafa.com/download/zarafa-vmime-patches.tar.gz
3
4#######Essential package info.
5#Change these if autodetection fails.
6
7#Name of the Syn-3 package that we are going to create
8NAME=`basename $0|sed 's/.SlackBuild//'`
9
10#Archive of the sourcefiles to unpack
11SRC_ARC=`ls *.tar.*`
12
13#Version of the sourcefiles
14VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g'`
15
16#Directory of the sourcefiles to build (after optional unpacking)
17SRC_DIR=`echo $SRC_ARC| sed 's/\.tar\..*$//g'`
18
19#Architecture that the created binaries run on.
20#Use noarch for scripts.
21ARCH=`uname -m`
22
23
24########Build and create the pacakge.
25#Uncomment the stuff that you dont want or need
26
27#Unpack source
28#(uncomment if not needed)
29syn3_unpack $SRC_ARC || exit 1
30
31#apply patches
32for PATCH in *.diff; do
33    patch -p1 -d $SRC_DIR < $PATCH|| exit 1
34done
35
36#build and install sourcefiles
37#./configure optiones:
38export CONFIGURE_OPTS="--disable-sasl --disable-tls"
39#options for all make commands:
40export MAKE_OPTS=""
41#skip testing:
42#export NOTEST=1
43#extra optiones for the make install command, use with INSTALL_BASE for example:
44export INSTALL_OPTS=""
45syn3_build_automake $SRC_DIR /tmp/pkg || exit 1
46
47
48mkdir -p /tmp/pkg/etc/postinst.d
49cp post.libvmime /tmp/pkg/etc/postinst.d
50chmod +x /tmp/pkg/etc/postinst.d/post.libvmime || exit 1
51
52#strip bins and other stuff
53syn3_strip /tmp/pkg || exit 1
54
55#move development stuff and create seperate development package
56syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
57syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
58
59#make main package
60syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
61
62
Note: See TracBrowser for help on using the repository browser.