Last change
on this file since 7c410f9 was
c5c522c,
checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago
|
initial commit, transferred from cleaned syn3 svn tree
|
-
Property mode set to
100755
|
File size:
571 bytes
|
Rev | Line | |
---|
[c5c522c] | 1 | #!/bin/bash |
---|
| 2 | |
---|
| 3 | NAME=stress |
---|
| 4 | VER=0.18.8 |
---|
| 5 | CWD=`pwd` |
---|
| 6 | PKGTMP=/tmp/pkgtmp |
---|
| 7 | TARNAME=$NAME |
---|
| 8 | |
---|
| 9 | mkdir -p $PKGTMP &>/dev/null |
---|
| 10 | |
---|
| 11 | tar -xzf $TARNAME-$VER.tar.gz || exit 1 |
---|
| 12 | |
---|
| 13 | cd $TARNAME-$VER || exit 1 |
---|
| 14 | ./configure --prefix=/usr --sysconfdir=/etc || exit 1 |
---|
| 15 | make || exit 1 |
---|
| 16 | #make test || exit 1 |
---|
| 17 | make INSTALL_PREFIX=$PKGTMP DESTDIR=$PKGTMP install || exit 1 |
---|
| 18 | |
---|
| 19 | |
---|
| 20 | mkdir -p $PKGTMP/usr/bin |
---|
| 21 | cp $CWD/syn3-stress $PKGTMP/usr/bin |
---|
| 22 | chmod +x $PKGTMP/usr/bin/syn3-stress || exit 1 |
---|
| 23 | |
---|
| 24 | cd "$PKGTMP" || exit 1 |
---|
| 25 | makepkg -l y -c n $CWD/$NAME.pkg > /dev/null && |
---|
| 26 | echo $VER > $CWD/$NAME.version && |
---|
| 27 | arch > $CWD/$NAME.arch |
---|
| 28 | |
---|
Note: See
TracBrowser
for help on using the repository browser.