source: npl/overig/xml_security_c/xml_security_c.SlackBuild @ 0105685

gcc484ntopperl-5.22
Last change on this file since 0105685 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 2.1 KB
Line 
1#!/bin/bash
2#DEP:xerces_c
3
4#######Essential package info.
5#Change these if autodetection fails.
6
7#Name of the Syn-3 package that we are going to create
8NAME=`basename $0|sed 's/.SlackBuild//'`
9
10#Archive of the sourcefiles to unpack
11SRC_ARC=`ls *.tar.* *.zip 2>/dev/null`
12
13#Version of the sourcefiles
14VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'`
15
16#Architecture that the created binaries run on.
17#Use noarch for scripts.
18ARCH=`uname -m`
19
20#from this point on, exit on errors:
21set -e
22
23########Build and create the pacakge.
24#Uncomment the stuff that you dont want or need
25
26#Unpack source
27#(uncomment if not needed)
28syn3_unpack $SRC_ARC
29
30#Directory where the sourcefiles are unpacked.
31#(you might have to adjust this if autodetection fails)
32SRC_DIR=`ls -c|head -1`
33
34#apply patches
35#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
36
37pushd $SRC_DIR
38
39#AUTOMAKE: Configure
40#Some usefull stuff you sometimes need to set:
41#export LDFLAGS="-L/usr/X11/lib/ -L/usr/lib/mysql/"
42#export LD_LIBRARY_PATH=/usr/lib/mysql
43#export VPATH=$LD_LIBRARY_PATH
44#export CFLAGS="-std=c89"
45#export CFLAGS="-fgnu89-inline" #If "multiple definition of `foo'" Also see http://gcc.gnu.org/gcc-4.3/porting_to.html
46MAKE_OPTS=""
47./configure --prefix=/usr  || exit 1
48
49#AUTOMAKE: Compile
50make $MAKE_OPTS || exit 1
51
52#AUTOMAKE: Test (optional)
53if grep ^test: Makefile; then
54        make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
55        make $MAKE_OPTS test || exit 1
56elif grep ^check: Makefile; then
57        make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
58        make $MAKE_OPTS check || exit 1
59fi
60
61#AUTOMAKE: Install
62mkdir -p /tmp/pkg &>/dev/null
63make pkgconfigdir=/usr/lib/pkgconfig install_prefix=/tmp/pkg DESTDIR=/tmp/pkg INSTALL_ROOT=/tmp/pkg install_root=/tmp/pkg $MAKE_OPTS install || exit 1
64popd
65
66#strip bins and other stuff
67syn3_strip /tmp/pkg || exit 1
68
69#move development stuff and create seperate development package
70syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
71syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
72
73#make main package
74syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
75
76
77
Note: See TracBrowser for help on using the repository browser.