source: npl/python/kaa_base/python_kaa_base.SlackBuild @ 0105685

gcc484ntopperl-5.22
Last change on this file since 0105685 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 1.3 KB
Line 
1#!/bin/bash
2# Generic python build script. (C)DatuX
3# Put in in a builddirectory with a python tarfile that contains a setup.py.
4# Please python_modulename for python modules.
5
6#DEP:python
7
8#######Essential package info.
9#Change these if autodetection fails.
10
11#Name of the Syn-3 package that we are going to create
12NAME=`basename $0|sed 's/.SlackBuild//'`
13
14#Archive of the sourcefiles to unpack
15SRC_ARC=`ls *.tar.*`
16
17#Version of the sourcefiles
18VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g'`
19
20#Directory of the sourcefiles to build (after optional unpacking)
21SRC_DIR=`echo $SRC_ARC| sed 's/\.tar\..*$//g'`
22
23#Architecture that the created binaries run on.
24#Use noarch for scripts.
25ARCH=`uname -m`
26
27
28########Build and create the pacakge.
29#Uncomment the stuff that you dont want or need
30
31#Unpack source
32#(uncomment if not needed)
33syn3_unpack $SRC_ARC || exit 1
34
35#apply patches
36#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
37
38pushd $SRC_DIR || exit 1
39python setup.py install --root=/tmp/pkg || exit 1
40popd
41
42#strip bins and other stuff
43syn3_strip /tmp/pkg || exit 1
44
45#move development stuff and create seperate development package
46syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
47syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
48
49#make main package
50syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
51
52
Note: See TracBrowser for help on using the repository browser.