source: npl/system/findutils/findutils.SlackBuild @ 0105685

gcc484ntopperl-5.22
Last change on this file since 0105685 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 4.1 KB
Line 
1#!/bin/sh
2
3# Copyright 2005-2009, 2010  Patrick J. Volkerding, Sebeka, Minnesota, USA
4# All rights reserved.
5#
6# Redistribution and use of this script, with or without modification, is
7# permitted provided that the following conditions are met:
8#
9# 1. Redistributions of this script must retain the above copyright
10#    notice, this list of conditions and the following disclaimer.
11#
12#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
13#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
14#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
15#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
16#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
17#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
18#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
19#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
20#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
21#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
22
23VERSION=4.4.2
24BUILD=${BUILD:-1}
25
26# Automatically determine the architecture we're building on:
27if [ -z "$ARCH" ]; then
28  case "$( uname -m )" in
29    i?86) export ARCH=i486 ;;
30    arm*) export ARCH=arm ;;
31    # Unless $ARCH is already set, use uname -m for all other archs:
32       *) export ARCH=$( uname -m ) ;;
33  esac
34fi
35
36NUMJOBS=${NUMJOBS:--j6}
37
38CWD=$(pwd)
39TMP=${TMP:-/tmp}
40PKG=$TMP/package-findutils
41
42if [ "$ARCH" = "i486" ]; then
43  SLKCFLAGS="-O2 -march=i486 -mtune=i686"
44elif [ "$ARCH" = "s390" ]; then
45  SLKCFLAGS="-O2"
46elif [ "$ARCH" = "x86_64" ]; then
47  SLKCFLAGS="-O2 -fPIC"
48fi
49
50rm -rf $PKG
51mkdir -p $TMP $PKG
52cd $TMP
53rm -rf findutils-$VERSION
54tar xvf $CWD/findutils-$VERSION.tar.?z* || exit 1
55cd findutils-$VERSION || exit 1
56
57chown -R root:root .
58find . \
59  \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
60  -exec chmod 755 {} \; -o \
61  \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
62  -exec chmod 644 {} \;
63
64# We use slocate instead of these:
65zcat $CWD/findutils.nolocate.diff.gz | patch -p1 --verbose || exit 1
66
67# Don't output warnings by default.  Let's make the crazy assumption that the
68# user actually does know what they are doing, and will use -warn if they'd
69# like to be yelled at.
70zcat $CWD/findutils.no.default.options.warnings.diff.gz | patch -p1 --verbose || exit 1
71
72# Feel free to change the "--without-fts" if you like find to be faster and
73# less reliable.  With the current setting, "find" will be non-fts(), and
74# ftsfind will still be there if you want to use it.
75CFLAGS="$SLKCFLAGS" \
76./configure \
77  --prefix=/usr \
78  --mandir=/usr/man \
79  --infodir=/usr/info \
80  --disable-locate \
81  --without-fts \
82  --build=$ARCH-slackware-linux
83
84make $NUMJOBS || make || exit 1
85make install DESTDIR=$PKG || exit 1
86
87find $PKG | xargs file | grep -e "executable" -e "shared object" \
88  | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
89
90mkdir -p $PKG/usr/doc/findutils-$VERSION
91cp -a \
92  AUTHORS COPYING* NEWS README* THANKS TODO \
93  $PKG/usr/doc/findutils-$VERSION
94
95# Compress and if needed symlink the man pages:
96if [ -d $PKG/usr/man ]; then
97  ( cd $PKG/usr/man
98    for manpagedir in $(find . -type d -name "man*") ; do
99      ( cd $manpagedir
100        for eachpage in $( find . -type l -maxdepth 1) ; do
101          ln -s $( readlink $eachpage ).gz $eachpage.gz
102          rm $eachpage
103        done
104        gzip -9 *.?
105      )
106    done
107  )
108fi
109
110# Compress info pages and purge "dir" file from the package:
111if [ -d $PKG/usr/info ]; then
112  ( cd $PKG/usr/info
113    rm -f dir
114    gzip -9 *
115  )
116fi
117
118mkdir -p $PKG/install
119cat $CWD/slack-desc > $PKG/install/slack-desc
120
121cd $PKG
122/sbin/makepkg -l y -c n $TMP/findutils-$VERSION-$ARCH-$BUILD.txz
123
124
125############ make syn3 packages
126cd $CWD
127for PKG in /tmp/package-*; do
128        NAME=`echo $PKG| sed 's/.*package-//'| sed 's/-/_/'`
129
130        #seperate dev-package
131        syn3_move_dev $PKG $PKG""_dev
132        syn3_makepkg $PKG""_dev $NAME""_dev $VERSION $ARCH || exit 1
133
134        #make main package
135        syn3_makepkg $PKG $NAME $VERSION $ARCH || exit 1
136done
Note: See TracBrowser for help on using the repository browser.