source: npl/system/iptables/iptables.SlackBuild @ 0105685

gcc484ntopperl-5.22
Last change on this file since 0105685 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 775 bytes
Line 
1#!/bin/bash
2#NEED:linux_src
3NAME=iptables
4VER=1.4.5
5CWD=`pwd`
6PKGTMP=/tmp/pkgtmp
7
8mkdir -p $PKGTMP &>/dev/null
9
10tar -xjf $NAME-$VER.tar.bz2 || exit 1
11cd $NAME-$VER || exit 1
12
13
14#IMQ patch
15patch -p1 < ../iptables-1.4.3.2-imq_xt.diff || exit 1
16chmod +x extensions/.IMQ-test* || exit 1
17
18
19./configure --prefix=/usr || exit 1
20make PREFIX=/usr || exit 1
21make PREFIX=/usr install DESTDIR=$PKGTMP || exit 1
22
23( cd $PKGTMP
24  find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
25  find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
26)
27
28
29cd "$PKGTMP" || exit 1
30makepkg -l y -c n $CWD/$NAME.pkg > /dev/null &&
31echo $VER > $CWD/$NAME.version &&
32arch > $CWD/$NAME.arch
33
Note: See TracBrowser for help on using the repository browser.