1 | #!/bin/sh |
---|
2 | |
---|
3 | # Copyright 2006, 2007, 2008, 2009, 2010, 2012, 2016 Patrick J. Volkerding, Sebeka, MN, USA |
---|
4 | # All rights reserved. |
---|
5 | # |
---|
6 | # Redistribution and use of this script, with or without modification, is |
---|
7 | # permitted provided that the following conditions are met: |
---|
8 | # |
---|
9 | # 1. Redistributions of this script must retain the above copyright |
---|
10 | # notice, this list of conditions and the following disclaimer. |
---|
11 | # |
---|
12 | # THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED |
---|
13 | # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF |
---|
14 | # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO |
---|
15 | # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, |
---|
16 | # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, |
---|
17 | # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; |
---|
18 | # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, |
---|
19 | # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR |
---|
20 | # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF |
---|
21 | # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. |
---|
22 | |
---|
23 | |
---|
24 | PKGNAM=syslinux |
---|
25 | VERSION=${VERSION:-6.03} |
---|
26 | BUILD=${BUILD:-1} |
---|
27 | |
---|
28 | # Automatically determine the architecture we're building on: |
---|
29 | if [ -z "$ARCH" ]; then |
---|
30 | case "$( uname -m )" in |
---|
31 | i?86) export ARCH=i586 ;; |
---|
32 | arm*) export ARCH=arm ;; |
---|
33 | # Unless $ARCH is already set, use uname -m for all other archs: |
---|
34 | *) export ARCH=$( uname -m ) ;; |
---|
35 | esac |
---|
36 | fi |
---|
37 | |
---|
38 | CWD=$(pwd) |
---|
39 | TMP=${TMP:-/tmp} |
---|
40 | PKG=$TMP/package-${PKGNAM} |
---|
41 | rm -rf $PKG |
---|
42 | mkdir -p $TMP $PKG |
---|
43 | |
---|
44 | cd $TMP |
---|
45 | rm -rf ${PKGNAM}-${VERSION} |
---|
46 | tar xvf $CWD/${PKGNAM}-$VERSION.tar.xz || exit 1 |
---|
47 | cd ${PKGNAM}-$VERSION |
---|
48 | |
---|
49 | # Make sure ownerships and permissions are sane: |
---|
50 | chown -R root:root . |
---|
51 | find . \ |
---|
52 | \( -perm 2777 -o -perm 2775 -o -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \ |
---|
53 | -exec chmod 755 {} \; -o \ |
---|
54 | \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \ |
---|
55 | -exec chmod 644 {} \; |
---|
56 | find . -type d -exec chmod u-s,g-s {} \; |
---|
57 | |
---|
58 | # Clean, then build only the installer programs using the supplied assembled |
---|
59 | # ldlinux.asm: |
---|
60 | # See: http://www.syslinux.org/wiki/index.php?title=Doc/distrib |
---|
61 | #make -j1 clean || exit 1 |
---|
62 | make -j1 installer || exit 1 |
---|
63 | |
---|
64 | # Install: |
---|
65 | make install INSTALLROOT=/tmp/package-syslinux || exit 1 |
---|
66 | |
---|
67 | #cp -a linux/syslinux-nomtools $PKG/usr/bin |
---|
68 | chmod 755 $PKG/usr/bin/* |
---|
69 | |
---|
70 | rm -rf $PKG/usr/share/syslinux/com32 |
---|
71 | |
---|
72 | # Compress and link manpages, if any: |
---|
73 | if [ -d $PKG/usr/man ]; then |
---|
74 | ( cd $PKG/usr/man |
---|
75 | for manpagedir in $(find . -type d -name "man*") ; do |
---|
76 | ( cd $manpagedir |
---|
77 | for eachpage in $( find . -type l -maxdepth 1) ; do |
---|
78 | ln -s $( readlink $eachpage ).gz $eachpage.gz |
---|
79 | rm $eachpage |
---|
80 | done |
---|
81 | gzip -9 *.? |
---|
82 | ) |
---|
83 | done |
---|
84 | ) |
---|
85 | fi |
---|
86 | |
---|
87 | # Add a documentation directory: |
---|
88 | mkdir -p $PKG/usr/doc/${PKGNAM}-$VERSION/{cmenu,com32} |
---|
89 | cp -a \ |
---|
90 | COPYING* NEWS README* \ |
---|
91 | doc \ |
---|
92 | $PKG/usr/doc/${PKGNAM}-$VERSION |
---|
93 | cp -a com32/LICENCE $PKG/usr/doc/${PKGNAM}-$VERSION/com32 |
---|
94 | ( cd com32/cmenu |
---|
95 | cp -a \ |
---|
96 | CHANGES HISTORY MANUAL MENU_FORMAT README TODO \ |
---|
97 | $PKG/usr/doc/${PKGNAM}-$VERSION/cmenu |
---|
98 | ) |
---|
99 | |
---|
100 | mkdir -p $PKG/install |
---|
101 | cat $CWD/slack-desc > $PKG/install/slack-desc |
---|
102 | |
---|
103 | cd $TMP/package-${PKGNAM} |
---|
104 | makepkg -l y -c n $TMP/${PKGNAM}-$VERSION-$ARCH-$BUILD.txz |
---|
105 | |
---|