gcc484ntopperl-5.22
Last change
on this file since 0105685 was
c5c522c,
checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago
|
initial commit, transferred from cleaned syn3 svn tree
|
-
Property mode set to
100755
|
File size:
1.4 KB
|
Line | |
---|
1 | #!/bin/bash |
---|
2 | ##NEED:gperf |
---|
3 | ##DEP:glib2 |
---|
4 | ##DEP:libusb |
---|
5 | |
---|
6 | NAME=udev |
---|
7 | TAR=rdiff-backup |
---|
8 | |
---|
9 | #LETOP: >=143 heeft sys/signalfd.h nodig, maar deze zit pas in een nieuwe glibc (2.9?) en vanaf kernel 2.6.27.x! |
---|
10 | #nieuwwere versies hebben ook blkid 2.20 nodig, deze zit weer in nieuwere utillinux (fix ik andere keer) |
---|
11 | VER=142 |
---|
12 | |
---|
13 | CWD=`pwd` |
---|
14 | PKGTMP=/tmp/pkgtmp |
---|
15 | |
---|
16 | mkdir -p $PKGTMP &>/dev/null |
---|
17 | |
---|
18 | tar -xjf $NAME-$VER.tar.bz2 || exit 1 |
---|
19 | |
---|
20 | cd $NAME-$VER || exit 1 |
---|
21 | ./configure --disable-extras --disable-introspection --prefix=/usr --exec-prefix= --sysconfdir=/etc || exit 1 |
---|
22 | make || exit 1 |
---|
23 | make DESTDIR=$PKGTMP EXTRAS=extras/* install || exit 1 |
---|
24 | |
---|
25 | mkdir -p $PKGTMP/etc/rc.d || exit 1 |
---|
26 | cp $CWD/rc.udev $PKGTMP/etc/rc.d || exit 1 |
---|
27 | chmod +x $PKGTMP/etc/rc.d/rc.udev || exit 1 |
---|
28 | |
---|
29 | mkdir -p $PKGTMP/etc/udev/scripts |
---|
30 | cp $CWD/make_extra_nodes.sh $PKGTMP/etc/udev/scripts || exit 1 |
---|
31 | chmod +x $PKGTMP/etc/udev/scripts/make_extra_nodes.sh || exit 1 |
---|
32 | |
---|
33 | chmod +x $PKGTMP/sbin || exit 1 |
---|
34 | |
---|
35 | mkdir -p $PKGTMP/etc/postinst.d || exit 1 |
---|
36 | cp $CWD/post.udevd $PKGTMP/etc/postinst.d || exit 1 |
---|
37 | chmod +x $PKGTMP/etc/postinst.d/* || exit 1 |
---|
38 | |
---|
39 | #we DONT want persistent network rules. |
---|
40 | #syn3 does this in a different way, for redundacy reasons and the fact that new hardware should start with eth0 again when a syn3 installation is moved. |
---|
41 | rm $PKGTMP/lib/udev/rules.d/75-persistent-net-generator.rules || exit 1 |
---|
42 | |
---|
43 | cd "$PKGTMP" || exit 1 |
---|
44 | makepkg -l y -c n $CWD/$NAME.pkg > /dev/null && |
---|
45 | echo $VER > $CWD/$NAME.version && |
---|
46 | arch > $CWD/$NAME.arch |
---|
47 | |
---|
Note: See
TracBrowser
for help on using the repository browser.