source: npl/system/udev/udev.SlackBuild @ 0105685

gcc484ntopperl-5.22
Last change on this file since 0105685 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 1.4 KB
Line 
1#!/bin/bash
2##NEED:gperf
3##DEP:glib2
4##DEP:libusb
5
6NAME=udev
7TAR=rdiff-backup
8
9#LETOP: >=143 heeft sys/signalfd.h nodig, maar deze zit pas in een nieuwe glibc (2.9?) en vanaf kernel 2.6.27.x!
10#nieuwwere versies hebben ook blkid 2.20 nodig, deze zit weer in nieuwere utillinux (fix ik andere keer)
11VER=142
12
13CWD=`pwd`
14PKGTMP=/tmp/pkgtmp
15
16mkdir -p $PKGTMP &>/dev/null
17
18tar -xjf $NAME-$VER.tar.bz2 || exit 1
19
20cd $NAME-$VER || exit 1
21./configure --disable-extras --disable-introspection --prefix=/usr --exec-prefix= --sysconfdir=/etc || exit 1
22make || exit 1
23make  DESTDIR=$PKGTMP EXTRAS=extras/* install || exit 1
24
25mkdir -p $PKGTMP/etc/rc.d || exit 1
26cp $CWD/rc.udev $PKGTMP/etc/rc.d || exit 1
27chmod +x $PKGTMP/etc/rc.d/rc.udev || exit 1
28
29mkdir -p $PKGTMP/etc/udev/scripts
30cp $CWD/make_extra_nodes.sh $PKGTMP/etc/udev/scripts || exit 1
31chmod +x $PKGTMP/etc/udev/scripts/make_extra_nodes.sh || exit 1
32
33chmod +x $PKGTMP/sbin || exit 1
34
35mkdir -p $PKGTMP/etc/postinst.d || exit 1
36cp $CWD/post.udevd $PKGTMP/etc/postinst.d || exit 1
37chmod +x $PKGTMP/etc/postinst.d/* || exit 1
38
39#we DONT want persistent network rules.
40#syn3 does this in a different way, for redundacy reasons and the fact that new hardware should start with eth0 again when a syn3 installation is moved.
41rm $PKGTMP/lib/udev/rules.d/75-persistent-net-generator.rules || exit 1
42
43cd "$PKGTMP" || exit 1
44makepkg -l y -c n $CWD/$NAME.pkg > /dev/null &&
45echo $VER > $CWD/$NAME.version &&
46arch > $CWD/$NAME.arch
47
Note: See TracBrowser for help on using the repository browser.