source: npl/system/util_vserver/util_vserver.SlackBuild @ 0105685

gcc484ntopperl-5.22
Last change on this file since 0105685 was c5c522c, checked in by Edwin Eefting <edwin@datux.nl>, 8 years ago

initial commit, transferred from cleaned syn3 svn tree

  • Property mode set to 100755
File size: 2.5 KB
Line 
1#!/bin/bash
2#Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
3#Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
4#Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
5##################################### Build dependency info:
6
7#Strict build-dependencies.
8#Only use when really neccesary, this will rebuild our package if the dependencie has changed:
9##DEP:linux
10##DEP:linux_src
11
12#Loose build-dependencies.
13#Use this to specify the packages that are required to build our package:
14##NEED:libcairo
15##NEED:glib
16##NEED:gtk+
17##NEED:glib2
18##NEED:gtk+2
19##NEED:xorg_lib
20##NEED:xorg_proto
21#DEP:iptables
22#DEP:vlan
23#DEP:iproute2
24#DEP:net_tools
25#DEP:e2fsprogs
26##DEP:openssl
27#DEP:dietlibc
28
29#######Essential package info.
30#Change these if autodetection fails.
31
32#Name of the Syn-3 package that we are going to create
33NAME=`basename $0|sed 's/.SlackBuild//'`
34
35#Archive of the sourcefiles to unpack
36SRC_ARC=`ls *.tar.*`
37
38#Version of the sourcefiles
39VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g'`
40
41#Directory of the sourcefiles to build (after optional unpacking)
42SRC_DIR=`echo $SRC_ARC| sed 's/\.tar\..*$//g'`
43
44#Architecture that the created binaries run on.
45#Use noarch for scripts.
46ARCH=`arch`
47
48
49########Build and create the pacakge.
50#Uncomment the stuff that you dont want or need
51
52#Unpack source
53#(uncomment if not needed)
54syn3_unpack $SRC_ARC || exit 1
55
56#apply patches
57#patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1
58
59#build and install sourcefiles
60#(use one of the other syn3_build_* scripts when needed)
61export CONFIGURE_OPTS="--sysconfdir=/etc  --with-vrootdir=/home/system/vservers --with-crypto-api=none --enable-dietlibc"
62export MAKE_OPTS=""
63export DIET=/opt/diet/bin/diet
64#export NOTEST=1
65syn3_build_automake $SRC_DIR /tmp/pkg || exit 1
66
67#zorg dat belangrijke shit in /home/system komt ivm backups
68mkdir -p /tmp/pkg/home/system || exit 1
69mkdir -p /tmp/pkg/home/system/vservers || exit 1
70mv /tmp/pkg/etc/vservers /tmp/pkg/home/system/vservers.conf || exit 1
71ln -s /home/system/vservers.conf /tmp/pkg/etc/vservers || exit 1
72
73#boot scripts
74cp -a root/* /tmp/pkg || exit 1
75
76#cleanup
77find /tmp/pkg -name .svn -exec rm -r "{}" \;
78
79#strip bins and other stuff
80syn3_strip /tmp/pkg || exit 1
81
82#move development stuff and create seperate development package
83syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
84syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
85
86#make main package
87syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
88
89
Note: See TracBrowser for help on using the repository browser.