Ignore:
Timestamp:
09/26/17 13:30:36 (8 years ago)
Author:
Edwin Eefting <edwin@datux.nl>
Branches:
master, perl-5.22
Children:
07ead96
Parents:
9ec1a22 (diff), c6da4cb (diff)
Note: this is a merge changeset, the changes displayed below correspond to the merge itself.
Use the (diff) links above to see all the changes relative to each parent.
Message:

Merge branch 'gcc484'

File:
1 edited

Legend:

Unmodified
Added
Removed
  • npl/overig/file/file.SlackBuild.orig

    r9ec1a22 r2758a4b  
    11#!/bin/sh
    22
    3 # Copyright 2005-2008, 2009, 2010, 2013  Patrick J. Volkerding, Sebeka, MN, USA
     3# Copyright 2005-2008, 2009, 2010, 2013, 2015  Patrick J. Volkerding, Sebeka, MN, USA
    44# All rights reserved.
    55#
     
    2929if [ -z "$ARCH" ]; then
    3030  case "$( uname -m )" in
    31     i?86) export ARCH=i486 ;;
     31    i?86) export ARCH=i586 ;;
    3232    arm*) export ARCH=arm ;;
    3333    # Unless $ARCH is already set, use uname -m for all other archs:
     
    3636fi
    3737
    38 if [ "$ARCH" = "i486" ]; then
    39   SLKCFLAGS="-O2 -march=i486 -mtune=i686"
     38if [ "$ARCH" = "i586" ]; then
     39  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
    4040  LIBDIRSUFFIX=""
    4141elif [ "$ARCH" = "i686" ]; then
     
    9898  --enable-fsect-man5 \
    9999  --disable-static \
    100   --build=$ARCH-slackware-linux
     100  --build=$ARCH-slackware-linux || exit 1
    101101
    102102# The generated $TMP/file-$VERSION/libtool is buggy.  I don't know if this is supposed
     
    106106make $NUMJOBS || make || exit 1
    107107make install DESTDIR=$PKG || exit 1
     108
     109# Ignore for now - still labeled as experimental
     110# Actually, let's ignore it until something needs it  :)  <volkerdi>
     111#cd python/
     112#  python setup.py build
     113#  python setup.py install --root=$PKG
     114#cd ..
    108115
    109116# Seems --disable-static has been ignored lately:
Note: See TracChangeset for help on using the changeset viewer.