Changeset 2758a4b for npl/overig/file/file.SlackBuild.orig
- Timestamp:
- 09/26/17 13:30:36 (8 years ago)
- Branches:
- master, perl-5.22
- Children:
- 07ead96
- Parents:
- 9ec1a22 (diff), c6da4cb (diff)
Note: this is a merge changeset, the changes displayed below correspond to the merge itself.
Use the(diff)
links above to see all the changes relative to each parent. - File:
-
- 1 edited
Legend:
- Unmodified
- Added
- Removed
-
npl/overig/file/file.SlackBuild.orig
r9ec1a22 r2758a4b 1 1 #!/bin/sh 2 2 3 # Copyright 2005-2008, 2009, 2010, 2013 Patrick J. Volkerding, Sebeka, MN, USA3 # Copyright 2005-2008, 2009, 2010, 2013, 2015 Patrick J. Volkerding, Sebeka, MN, USA 4 4 # All rights reserved. 5 5 # … … 29 29 if [ -z "$ARCH" ]; then 30 30 case "$( uname -m )" in 31 i?86) export ARCH=i 486 ;;31 i?86) export ARCH=i586 ;; 32 32 arm*) export ARCH=arm ;; 33 33 # Unless $ARCH is already set, use uname -m for all other archs: … … 36 36 fi 37 37 38 if [ "$ARCH" = "i 486" ]; then39 SLKCFLAGS="-O2 -march=i 486 -mtune=i686"38 if [ "$ARCH" = "i586" ]; then 39 SLKCFLAGS="-O2 -march=i586 -mtune=i686" 40 40 LIBDIRSUFFIX="" 41 41 elif [ "$ARCH" = "i686" ]; then … … 98 98 --enable-fsect-man5 \ 99 99 --disable-static \ 100 --build=$ARCH-slackware-linux 100 --build=$ARCH-slackware-linux || exit 1 101 101 102 102 # The generated $TMP/file-$VERSION/libtool is buggy. I don't know if this is supposed … … 106 106 make $NUMJOBS || make || exit 1 107 107 make install DESTDIR=$PKG || exit 1 108 109 # Ignore for now - still labeled as experimental 110 # Actually, let's ignore it until something needs it :) <volkerdi> 111 #cd python/ 112 # python setup.py build 113 # python setup.py install --root=$PKG 114 #cd .. 108 115 109 116 # Seems --disable-static has been ignored lately:
Note: See TracChangeset
for help on using the changeset viewer.