- Timestamp:
- 09/20/18 18:43:08 (7 years ago)
- Branches:
- master, perl-5.22
- Children:
- c9755c3
- Parents:
- c9ea2dd
- File:
-
- 1 edited
Legend:
- Unmodified
- Added
- Removed
-
npl/system/ca_certificates/ca-certificates.SlackBuild.orig
rc9ea2dd r4933918 1 #!/bin/ bash1 #!/bin/sh 2 2 3 3 # Slackware build script for ca-certificates 4 4 5 5 # Copyright 2009,2011 Robby Workman Northport, AL, USA 6 # Copyright 2012, 2013, 2015, 2016 , 2018Patrick J. Volkerding, Sebeka, MN, USA6 # Copyright 2012, 2013, 2015, 2016 Patrick J. Volkerding, Sebeka, MN, USA 7 7 # All rights reserved. 8 8 # … … 24 24 # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. 25 25 26 cd $(dirname $0) ; CWD=$(pwd) 26 PKGNAM=ca-certificates 27 VERSION=${VERSION:-20161130} 28 ARCH=noarch 29 BUILD=${BUILD:-1_slack14.2} 27 30 28 PKGNAM=ca-certificates 29 VERSION=${VERSION:-20180409} 30 ARCH=noarch 31 BUILD=${BUILD:-1} 31 TARVERSION=${VERSION}+nmu1 32 32 33 # If the variable PRINT_PACKAGE_NAME is set, then this script will report what 34 # the name of the created package would be, and then exit. This information 35 # could be useful to other scripts. 36 if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then 37 echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz" 38 exit 0 39 fi 40 41 TARVERSION=${VERSION} 42 33 CWD=$(pwd) 43 34 TMP=${TMP:-/tmp} 44 35 PKG=$TMP/package-$PKGNAM … … 56 47 57 48 # Again, both $PKGNAM and $PKGNAM-$VERSION are needed here: 58 cd $PKGNAM-$VERSION 2> /dev/null|| cd $PKGNAM || exit 149 cd $PKGNAM-$VERSION || cd $PKGNAM || exit 1 59 50 60 51 chown -R root:root . … … 86 77 87 78 mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION 88 #mv debian/NEWS debian/NEWS.Debian89 cp -a debian/README.Debian $PKG/usr/doc/$PKGNAM-$VERSION79 mv debian/NEWS debian/NEWS.Debian 80 cp -a debian/NEWS.Debian debian/README.Debian $PKG/usr/doc/$PKGNAM-$VERSION 90 81 91 82 mkdir -p $PKG/var/log/setup
Note: See TracChangeset
for help on using the changeset viewer.