Changeset 6a55355 for npl/system/libmnl/libmnl.SlackBuild
- Timestamp:
- 01/19/17 22:55:00 (8 years ago)
- Branches:
- gcc484, master, ntop, perl-5.22
- Children:
- f2411e4
- Parents:
- 8f290a0
- File:
-
- 1 edited
Legend:
- Unmodified
- Added
- Removed
-
npl/system/libmnl/libmnl.SlackBuild
r8f290a0 r6a55355 1 1 #!/bin/bash 2 #Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild 3 #Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven. 4 #Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden. 5 ##################################### Build dependency info: 6 7 #Strict build-dependencies 8 #Our package will be automaticly rebuilded if there is a major change in a DEP package. 9 #(this is recommended for most dependencys) 10 ##DEP:linux 11 ##DEP:linux_src 12 ##DEP:openldap 13 14 #Loose build-dependencies 15 #The package will be installed in the buildroot during buidling, but no automatic rebuild will occur. 16 #(not recommended) 17 ##NEED:doxygen 18 19 #######Essential package info. 20 #Change these if autodetection fails. 21 22 #Name of the Syn-3 package that we are going to create 23 NAME=`basename $0|sed 's/.SlackBuild//'` 24 25 #Archive of the sourcefiles to unpack 26 SRC_ARC=`ls *.tar.* *.zip 2>/dev/null` 27 28 #Version of the sourcefiles 29 VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'` 30 31 #Architecture that the created binaries run on. 32 #Use noarch for scripts. 33 ARCH=`uname -m` 34 35 #from this point on, exit on errors: 36 set -e 37 38 ########Build and create the pacakge. 39 #Uncomment the stuff that you dont want or need 40 41 #Unpack source 42 #(uncomment if not needed) 43 syn3_unpack $SRC_ARC 44 45 #Directory where the sourcefiles are unpacked. 46 #(you might have to adjust this if autodetection fails) 47 SRC_DIR=`ls -c|head -1` 48 49 #apply patches 50 #patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1 51 52 pushd $SRC_DIR 53 54 #AUTOMAKE: Configure 55 #Some usefull stuff you sometimes need to set: 56 #export LDFLAGS="-L/usr/X11/lib/ -L/usr/lib/mysql/" 57 #export LD_LIBRARY_PATH=/usr/lib/mysql 58 #export VPATH=$LD_LIBRARY_PATH 59 #export CFLAGS="-std=c89" 60 #export CFLAGS="-fgnu89-inline" #If "multiple definition of `foo'" Also see http://gcc.gnu.org/gcc-4.3/porting_to.html 61 MAKE_OPTS="" 62 ./configure --prefix=/usr || exit 1 63 64 #AUTOMAKE: Compile 65 make $MAKE_OPTS || exit 1 66 67 #AUTOMAKE: Test (optional) 68 if grep ^test: Makefile; then 69 make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1 70 make $MAKE_OPTS test || exit 1 71 elif grep ^check: Makefile; then 72 make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1 73 make $MAKE_OPTS check || exit 1 74 fi 75 76 #AUTOMAKE: Install 77 mkdir -p /tmp/pkg &>/dev/null 78 make pkgconfigdir=/usr/lib/pkgconfig install_prefix=/tmp/pkg DESTDIR=/tmp/pkg INSTALL_ROOT=/tmp/pkg install_root=/tmp/pkg $MAKE_OPTS install || exit 1 79 popd 80 81 #strip bins and other stuff 82 syn3_strip /tmp/pkg || exit 1 83 84 #move development stuff and create seperate development package 85 syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1 86 syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1 87 88 #make main package 89 syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1 2 # 3 # Automaticly created by importpackage v1.0 4 # Imported from: http://mirrors.slackware.com/slackware/slackware-current/source/n/libmnl/ 5 # Created at Thu Jan 19 22:29:07 CET 2017 90 6 91 7 8 ########### source original slackbuild (hopefully we dont need to modify it) 9 CWD=`pwd` 10 set -e 11 source ./libmnl.SlackBuild.orig 92 12 13 14 ############ make syn3 packages 15 cd $CWD 16 for PKG in /tmp/package-*; do 17 NAME=`echo $PKG| sed 's/.*package-//'| sed 's/-/_/g'` 18 19 #seperate dev-package 20 syn3_move_dev $PKG $PKG""_dev 21 syn3_makepkg $PKG""_dev $NAME""_dev $VERSION $ARCH || exit 1 22 23 #make main package 24 syn3_makepkg $PKG $NAME $VERSION $ARCH || exit 1 25 done
Note: See TracChangeset
for help on using the changeset viewer.