Changeset 80c0fb9 for npl/fileserver/samba/samba.SlackBuild.orig
- Timestamp:
- 03/14/18 18:03:01 (7 years ago)
- Branches:
- gcc484, master, perl-5.22
- Children:
- b26e5aa, fdfd619
- Parents:
- 250d444
- File:
-
- 1 edited
Legend:
- Unmodified
- Added
- Removed
-
npl/fileserver/samba/samba.SlackBuild.orig
r250d444 r80c0fb9 1 1 #!/bin/sh 2 2 3 # Copyright 2008, 2009, 2010, 2012, 2013, 2015, 2016 Patrick J. Volkerding, Sebeka, Minnesota, USA3 # Copyright 2008, 2009, 2010, 2012, 2013, 2015, 2016, 2017 Patrick J. Volkerding, Sebeka, Minnesota, USA 4 4 # All rights reserved. 5 5 # … … 24 24 25 25 26 VERSION=${VERSION:-$(echo samba-*.tar. gz | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}27 BUILD=${BUILD:- 3}26 VERSION=${VERSION:-$(echo samba-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)} 27 BUILD=${BUILD:-1} 28 28 29 29 if [ -e $CWD/machine.conf ]; then … … 68 68 mkdir -p $TMP $PKG 69 69 70 if [ -r /usr/lib${LIBDIRSUFFIX}/libtalloc.so.? -a ! -r /var/log/packages/talloc* ]; then71 echo "The Samba package needs to be removed before building to ensure that"72 echo "talloc (and possibly other bundled libraries) are included in the build."73 echo74 echo "Removing the Samba package in 15 seconds, and then continuing with the build."75 sleep 1576 removepkg samba77 fi78 79 70 cd $TMP 80 71 rm -rf samba-$VERSION 81 tar xvf $CWD/samba-$VERSION.tar. gz || exit 172 tar xvf $CWD/samba-$VERSION.tar.?z || exit 1 82 73 cd samba-$VERSION || exit 1 83 84 # Patch to install talloc/tevent/tdb libraries and includes:85 zcat $CWD/samba.install.talloc.tevent.tdb.diff.gz | patch -p1 --verbose || exit 186 74 87 75 if [ ! -d source3/lib/cmdline ]; then … … 133 121 --with-ads \ 134 122 --without-pam \ 135 --build=$TARGET 123 --build=$TARGET || exit 1 136 124 # Gives errors: 137 125 #--builtin-libraries=replace,ccan \ … … 139 127 140 128 # -j options don't seem to work... [Yes they do! At least try to use -j below...] 141 JOBS= 1142 MAXJOBS= 20129 JOBS=6 130 MAXJOBS=6 143 131 export JOBS MAXJOBS 144 132 make -j $MAXJOBS || make || exit 1 … … 174 162 chmod 644 $PKG/etc/rc.d/rc.samba.new 175 163 176 # mv $PKG/usr/share/man $PKG/usr177 # gzip -9 $PKG/usr/man/man?/*.?164 # mv $PKG/usr/share/man $PKG/usr 165 # gzip -9 $PKG/usr/man/man?/*.? 178 166 179 167 find $PKG | xargs file | grep -e "executable" -e "shared object" \ … … 181 169 182 170 # PAM related stuff we don't use: 183 # rm -r $PKG/usr/share/locale171 # rm -r $PKG/usr/share/locale 184 172 rm -f $PKG/usr/man/man8/pam* 185 173 186 174 cp -a \ 187 COPYING* PFIF.txt README* \188 R oadmap WHATSNEW.txt docs examples \189 $PKG/usr/doc/samba-$VERSION 175 COPYING* MAINTAINERS Manifest PFIF.txt README* \ 176 Read-Manifest-Now Roadmap WHATSNEW.txt docs examples \ 177 $PKG/usr/doc/samba-$VERSION || true 190 178 # These are installed elsewhere: 191 179 rm -rf $PKG/usr/doc/samba-$VERSION/docs/htmldocs \ … … 216 204 cd $PKG 217 205 /sbin/makepkg -l y -c n $TMP/samba-$VERSION-$ARCH-$BUILD.txz 218
Note: See TracChangeset
for help on using the changeset viewer.