Ignore:
Timestamp:
03/14/18 18:03:01 (7 years ago)
Author:
Edwin Eefting <edwin@datux.nl>
Branches:
gcc484, master, perl-5.22
Children:
b26e5aa, fdfd619
Parents:
250d444
Message:

samba upgrade to 4.7.6

File:
1 edited

Legend:

Unmodified
Added
Removed
  • npl/fileserver/samba/samba.SlackBuild.orig

    r250d444 r80c0fb9  
    11#!/bin/sh
    22
    3 # Copyright 2008, 2009, 2010, 2012, 2013, 2015, 2016  Patrick J. Volkerding, Sebeka, Minnesota, USA
     3# Copyright 2008, 2009, 2010, 2012, 2013, 2015, 2016, 2017  Patrick J. Volkerding, Sebeka, Minnesota, USA
    44# All rights reserved.
    55#
     
    2424
    2525
    26 VERSION=${VERSION:-$(echo samba-*.tar.gz | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
    27 BUILD=${BUILD:-3}
     26VERSION=${VERSION:-$(echo samba-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
     27BUILD=${BUILD:-1}
    2828
    2929if [ -e $CWD/machine.conf ]; then
     
    6868mkdir -p $TMP $PKG
    6969
    70 if [ -r /usr/lib${LIBDIRSUFFIX}/libtalloc.so.? -a ! -r /var/log/packages/talloc* ]; then
    71   echo "The Samba package needs to be removed before building to ensure that"
    72   echo "talloc (and possibly other bundled libraries) are included in the build."
    73   echo
    74   echo "Removing the Samba package in 15 seconds, and then continuing with the build."
    75   sleep 15
    76   removepkg samba
    77 fi
    78 
    7970cd $TMP
    8071rm -rf samba-$VERSION
    81 tar xvf $CWD/samba-$VERSION.tar.gz || exit 1
     72tar xvf $CWD/samba-$VERSION.tar.?z || exit 1
    8273cd samba-$VERSION || exit 1
    83 
    84 # Patch to install talloc/tevent/tdb libraries and includes:
    85 zcat $CWD/samba.install.talloc.tevent.tdb.diff.gz | patch -p1 --verbose || exit 1
    8674
    8775if [ ! -d source3/lib/cmdline ]; then
     
    133121  --with-ads \
    134122  --without-pam \
    135   --build=$TARGET
     123  --build=$TARGET || exit 1
    136124  # Gives errors:
    137125  #--builtin-libraries=replace,ccan \
     
    139127
    140128# -j options don't seem to work... [Yes they do!  At least try to use -j below...]
    141 JOBS=1
    142 MAXJOBS=20
     129JOBS=6
     130MAXJOBS=6
    143131export JOBS MAXJOBS
    144132make -j $MAXJOBS || make || exit 1
     
    174162chmod 644 $PKG/etc/rc.d/rc.samba.new
    175163
    176 #mv $PKG/usr/share/man $PKG/usr
    177 #gzip -9 $PKG/usr/man/man?/*.?
     164# mv $PKG/usr/share/man $PKG/usr
     165# gzip -9 $PKG/usr/man/man?/*.?
    178166
    179167find $PKG | xargs file | grep -e "executable" -e "shared object" \
     
    181169
    182170# PAM related stuff we don't use:
    183 #rm -r $PKG/usr/share/locale
     171# rm -r $PKG/usr/share/locale
    184172rm -f $PKG/usr/man/man8/pam*
    185173
    186174cp -a \
    187   COPYING* PFIF.txt README* \
    188   Roadmap WHATSNEW.txt docs examples \
    189   $PKG/usr/doc/samba-$VERSION
     175  COPYING* MAINTAINERS Manifest PFIF.txt README* \
     176  Read-Manifest-Now Roadmap WHATSNEW.txt docs examples \
     177  $PKG/usr/doc/samba-$VERSION || true
    190178# These are installed elsewhere:
    191179rm -rf $PKG/usr/doc/samba-$VERSION/docs/htmldocs \
     
    216204cd $PKG
    217205/sbin/makepkg -l y -c n $TMP/samba-$VERSION-$ARCH-$BUILD.txz
    218 
Note: See TracChangeset for help on using the changeset viewer.