Ignore:
Timestamp:
11/13/21 00:26:27 (3 years ago)
Author:
Edwin Eefting <edwin@datux.nl>
Branches:
master
Children:
892871d
Parents:
7c410f9
Message:

trying kernel 5.14

File:
1 edited

Legend:

Unmodified
Added
Removed
  • npl/internetserver/iproute2/iproute2.SlackBuild

    r7c410f9 r929bb42  
    11#!/bin/bash
    2 #Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild
    3 #Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.
    4 #Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.
    5 ##################################### Build dependency info:
    6 
    7 #Strict build-dependencies
    8 #Our package will be automaticly rebuilded if there is a major change in a DEP package.
    9 #(this is recommended for most dependencys)
    10 ##DEP:linux
    11 ##DEP:linux_src
    12 ##DEP:openldap
    13 #NEED:iptables
    14 
    15 #Loose build-dependencies
    16 #The package will be installed in the buildroot during buidling, but no automatic rebuild will occur.
    17 #(not recommended)
    18 ##NEED:doxygen
    19 
    20 #######Essential package info.
    21 #Change these if autodetection fails.
    22 
    23 #Name of the Syn-3 package that we are going to create
    24 NAME=`basename $0|sed 's/.SlackBuild//'`
    25 
    26 #Archive of the sourcefiles to unpack
    27 SRC_ARC=`ls *.tar.* *.zip 2>/dev/null`
    28 
    29 #Version of the sourcefiles
    30 VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g' | sed 's/\.zip$//g'`
    31 
    32 #Architecture that the created binaries run on.
    33 #Use noarch for scripts.
    34 ARCH=`uname -m`
    35 
    36 #from this point on, exit on errors:
    37 set -e
    38 
    39 ########Build and create the pacakge.
    40 #Uncomment the stuff that you dont want or need
    41 
    42 #Unpack source
    43 #(uncomment if not needed)
    44 syn3_unpack $SRC_ARC
    45 
    46 #Directory where the sourcefiles are unpacked.
    47 #(you might have to adjust this if autodetection fails)
    48 SRC_DIR=`ls -c|head -1`
    49 
    50 ####### ALL KINDS OF HACKS/PATCHES FROM THE GENTOO FOLKS:
    51 
    52 #patch -F3 -p1 -d $SRC_DIR < iproute2-2.6.26-ldflags.patch || exit 1
    53 patch -p1 -d $SRC_DIR < iproute2-2.6.29.1-flush.patch || exit 1
    54 
    55 pushd $SRC_DIR
    56 
    57 # build against system headers
    58 #rm -r include/netinet #include/linux include/ip{,6}tables{,_common}.h include/libiptc
    59 
    60 # Use correct iptables dir, #144265
    61 #sed -i "s:/usr/local/lib/iptables:/usr/lib/iptables:g" include/iptables.h
    62 #EDWIN: hmm..werkt niet, wil x_tables.h ipv xtables.h?
     2#
     3# Automaticly created by importpackage v1.0
     4# Imported from: https://mirror.slackbuilds.org/slackware/slackware-14.2/source/n/iproute2/
     5# Created at do 12 nov 2020  0:08:08 CET
    636
    647
    65 #disable berklydb stuff
    66 sed -i '/^TARGETS=/s: arpd : :' misc/Makefile || exit 1
     8########### source original slackbuild (hopefully we dont need to modify it)
     9CWD=`pwd`
     10set -e
     11source ./iproute2.SlackBuild.orig
    6712
    6813
    69 #AUTOMAKE: Configure
    70 #Some usefull stuff you sometimes need to set:
    71 #export LDFLAGS="-L/usr/X11/lib/ -L/usr/lib/mysql/"
    72 #export LD_LIBRARY_PATH=/usr/lib/mysql
    73 #export VPATH=$LD_LIBRARY_PATH
    74 MAKE_OPTS=""
    75 ./configure --prefix=/usr  || exit 1
     14############ make syn3 packages
     15cd $CWD
     16for PKG in /tmp/package-*; do
     17        NAME=`echo $PKG| sed 's/.*package-//'| sed 's/-/_/g'`
    7618
    77 #AUTOMAKE: Compile
    78 make $MAKE_OPTS || exit 1
     19        #seperate dev-package
     20        syn3_move_dev $PKG $PKG""_dev
     21        syn3_makepkg $PKG""_dev $NAME""_dev $VERSION $ARCH || exit 1
    7922
    80 #AUTOMAKE: Test (optional)
    81 if grep ^test: Makefile; then
    82         make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
    83         make $MAKE_OPTS test || exit 1
    84 elif grep ^check: Makefile; then
    85         make pkgconfigdir=/usr/lib/pkgconfig $MAKE_OPTS install || exit 1
    86         make $MAKE_OPTS check || exit 1
    87 fi
    88 
    89 #AUTOMAKE: Install
    90 mkdir -p /tmp/pkg &>/dev/null
    91 make DESTDIR=/tmp/pkg DOCDIR=/usr/share/doc/iproute2 MANDIR=/usr/share/man $MAKE_OPTS install || exit 1
    92 popd
    93 
    94 find /tmp/pkg/etc -follow -type f -exec mv "{}" "{}.new" \; || exit 1
    95 
    96 
    97 #strip bins and other stuff
    98 syn3_strip /tmp/pkg || exit 1
    99 
    100 #move development stuff and create seperate development package
    101 syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1
    102 syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1
    103 
    104 #make main package
    105 syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1
    106 
    107 
    108 
     23        #make main package
     24        syn3_makepkg $PKG $NAME $VERSION $ARCH || exit 1
     25done
Note: See TracChangeset for help on using the changeset viewer.