Changeset 929bb42 for npl/kernel/linux_src/linux_src.SlackBuild
- Timestamp:
- 11/13/21 00:26:27 (3 years ago)
- Branches:
- master
- Children:
- 892871d
- Parents:
- 7c410f9
- File:
-
- 1 edited
Legend:
- Unmodified
- Added
- Removed
-
npl/kernel/linux_src/linux_src.SlackBuild
r7c410f9 r929bb42 1 1 #!/bin/bash 2 2 #NEED:ncurses_dev 3 #DEP:openssl 3 4 4 5 NAME=linux_src … … 14 15 15 16 #unpack basic kernel and apply all incremental patches 16 tar -xf $CWD/linux-5.1 0.tar.xz || exit 117 tar -xf $CWD/linux-5.14.tar.xz || exit 1 17 18 cd linux-* || exit 1 18 19 #if you want to create a newer kernel: just download newest patches, and increase patchlevel 19 20 #also increase .major file to trigger rebuilds! 20 PATCHLEVEL= 7321 VER=5.1 0.$PATCHLEVEL21 PATCHLEVEL=12 22 VER=5.14.$PATCHLEVEL 22 23 #bunzip2 $CWD/patch-$VER.bz2 || exit 1 23 24 #gunzip $CWD/patch-$VER.gz || exit 1 … … 49 50 #patch -F3 -p1 < $CWD/4200_fbcondecor.patch || exit 1 50 51 #from https://raw.githubusercontent.com/jirka-grunt/fbcondecor/master/fbcondecor-5.10.patch 51 patch -p1 < $CWD/fbcondecor-5.10.patch || exit 152 #patch -p1 < $CWD/fbcondecor-5.10.patch || exit 1 52 53 53 54 … … 62 63 #patch -p1 < $CWD/linux-4.14-imq.diff || exit 1 63 64 #from https://raw.githubusercontent.com/imq/linuximq/master/kernel/v5.x/linux-5.9-imq.patch 64 patch -p1 < $CWD/linux-5.9-imq.patch || exit 165 #patch -p1 < $CWD/linux-5.9-imq.patch || exit 1 65 66 66 67
Note: See TracChangeset
for help on using the changeset viewer.