Ignore:
Timestamp:
11/13/21 00:26:27 (3 years ago)
Author:
Edwin Eefting <edwin@datux.nl>
Branches:
master
Children:
892871d
Parents:
7c410f9
Message:

trying kernel 5.14

File:
1 edited

Legend:

Unmodified
Added
Removed
  • npl/kernel/linux_src/linux_src.SlackBuild

    r7c410f9 r929bb42  
    11#!/bin/bash
    22#NEED:ncurses_dev
     3#DEP:openssl
    34
    45NAME=linux_src
     
    1415
    1516#unpack basic kernel and apply all incremental patches
    16 tar -xf $CWD/linux-5.10.tar.xz || exit 1
     17tar -xf $CWD/linux-5.14.tar.xz || exit 1
    1718cd linux-* || exit 1
    1819#if you want to create a newer kernel: just download newest patches, and increase patchlevel
    1920#also increase .major file to trigger rebuilds!
    20 PATCHLEVEL=73
    21 VER=5.10.$PATCHLEVEL
     21PATCHLEVEL=12
     22VER=5.14.$PATCHLEVEL
    2223#bunzip2 $CWD/patch-$VER.bz2 || exit 1
    2324#gunzip $CWD/patch-$VER.gz || exit 1
     
    4950#patch  -F3 -p1 < $CWD/4200_fbcondecor.patch || exit 1
    5051#from https://raw.githubusercontent.com/jirka-grunt/fbcondecor/master/fbcondecor-5.10.patch
    51 patch   -p1 < $CWD/fbcondecor-5.10.patch || exit 1
     52#patch   -p1 < $CWD/fbcondecor-5.10.patch || exit 1
    5253
    5354
     
    6263#patch -p1  < $CWD/linux-4.14-imq.diff || exit 1
    6364#from https://raw.githubusercontent.com/imq/linuximq/master/kernel/v5.x/linux-5.9-imq.patch
    64 patch -p1 < $CWD/linux-5.9-imq.patch || exit 1
     65#patch -p1 < $CWD/linux-5.9-imq.patch || exit 1
    6566
    6667
Note: See TracChangeset for help on using the changeset viewer.