Ignore:
Timestamp:
01/11/19 22:38:23 (6 years ago)
Author:
Edwin Eefting <edwin@datux.nl>
Branches:
master
Children:
834b847
Parents:
6936b89
Message:

iptables upgrade for kernel 4.9

File:
1 edited

Legend:

Unmodified
Added
Removed
  • npl/system/iptables/iptables.SlackBuild.orig

    • Property mode changed from 100755 to 100644
    r6936b89 r94a6f37  
    1 #!/bin/sh
     1#!/bin/bash
    22
    3 # Copyright 2008, 2009, 2010, 2012, 2013  Patrick J. Volkerding, Sebeka, MN, USA
     3# Copyright 2008, 2009, 2010, 2012, 2013, 2018  Patrick J. Volkerding, Sebeka, MN, USA
    44# All rights reserved.
    55#
     
    2121#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
    2222
    23 VERSION=${VERSION:-$(echo iptables-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
    24 BUILD=${BUILD:-2}
     23cd $(dirname $0) ; CWD=$(pwd)
    2524
    26 NUMJOBS=${NUMJOBS:-" -j7 "}
     25PKGNAM=iptables
     26VERSION=${VERSION:-$(echo iptables-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
     27BUILD=${BUILD:-1}
     28
     29NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
    2730
    2831# Automatically determine the architecture we're building on:
     
    3639fi
    3740
    38 CWD=$(pwd)
     41# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
     42# the name of the created package would be, and then exit. This information
     43# could be useful to other scripts.
     44if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
     45  echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
     46  exit 0
     47fi
     48
    3949TMP=${TMP:-/tmp}
    4050PKG=$TMP/package-iptables
     
    5868cd $TMP
    5969rm -rf iptables-$VERSION
    60 tar xvf $CWD/iptables-$VERSION.tar.?z* || exit 1
     70tar xvf $CWD/iptables-$VERSION.tar.?z || exit 1
    6171cd iptables-$VERSION || exit 1
    6272
     
    8494make $NUMJOBS || make || exit 1
    8595make install DESTDIR=$PKG || exit 1
     96
     97# Don't ship .la files:
     98rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
    8699
    87100find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
Note: See TracChangeset for help on using the changeset viewer.