Changeset 94a6f37 for npl/system/iptables/iptables.SlackBuild.orig
- Timestamp:
- 01/11/19 22:38:23 (6 years ago)
- Branches:
- master
- Children:
- 834b847
- Parents:
- 6936b89
- File:
-
- 1 edited
Legend:
- Unmodified
- Added
- Removed
-
npl/system/iptables/iptables.SlackBuild.orig
-
Property
mode
changed from
100755
to100644
r6936b89 r94a6f37 1 #!/bin/ sh1 #!/bin/bash 2 2 3 # Copyright 2008, 2009, 2010, 2012, 2013 Patrick J. Volkerding, Sebeka, MN, USA3 # Copyright 2008, 2009, 2010, 2012, 2013, 2018 Patrick J. Volkerding, Sebeka, MN, USA 4 4 # All rights reserved. 5 5 # … … 21 21 # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. 22 22 23 VERSION=${VERSION:-$(echo iptables-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)} 24 BUILD=${BUILD:-2} 23 cd $(dirname $0) ; CWD=$(pwd) 25 24 26 NUMJOBS=${NUMJOBS:-" -j7 "} 25 PKGNAM=iptables 26 VERSION=${VERSION:-$(echo iptables-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)} 27 BUILD=${BUILD:-1} 28 29 NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "} 27 30 28 31 # Automatically determine the architecture we're building on: … … 36 39 fi 37 40 38 CWD=$(pwd) 41 # If the variable PRINT_PACKAGE_NAME is set, then this script will report what 42 # the name of the created package would be, and then exit. This information 43 # could be useful to other scripts. 44 if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then 45 echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz" 46 exit 0 47 fi 48 39 49 TMP=${TMP:-/tmp} 40 50 PKG=$TMP/package-iptables … … 58 68 cd $TMP 59 69 rm -rf iptables-$VERSION 60 tar xvf $CWD/iptables-$VERSION.tar.?z *|| exit 170 tar xvf $CWD/iptables-$VERSION.tar.?z || exit 1 61 71 cd iptables-$VERSION || exit 1 62 72 … … 84 94 make $NUMJOBS || make || exit 1 85 95 make install DESTDIR=$PKG || exit 1 96 97 # Don't ship .la files: 98 rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la 86 99 87 100 find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \ -
Property
mode
changed from
Note: See TracChangeset
for help on using the changeset viewer.