Changeset 94a6f37 for npl/system/libnftnl/libnftnl.SlackBuild.orig
- Timestamp:
- 01/11/19 22:38:23 (6 years ago)
- Branches:
- master
- Children:
- 834b847
- Parents:
- 6936b89
- File:
-
- 1 edited
Legend:
- Unmodified
- Added
- Removed
-
npl/system/libnftnl/libnftnl.SlackBuild.orig
-
Property
mode
changed from
100755
to100644
r6936b89 r94a6f37 1 #!/bin/ sh1 #!/bin/bash 2 2 3 # Copyright 2014 Patrick J. Volkerding, Sebeka, Minnesota, USA3 # Copyright 2014, 2018 Patrick J. Volkerding, Sebeka, Minnesota, USA 4 4 # All rights reserved. 5 5 # … … 21 21 # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. 22 22 23 cd $(dirname $0) ; CWD=$(pwd) 24 23 25 PKGNAM=libnftnl 24 VERSION=${VERSION:-$(echo $PKGNAM-*.tar. xz | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}26 VERSION=${VERSION:-$(echo $PKGNAM-*.tar.lz | rev | cut -f 3- -d . | cut -f 1 -d - | rev)} 25 27 BUILD=${BUILD:-1} 26 28 27 NUMJOBS=${NUMJOBS:-" -j 7"}29 NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "} 28 30 29 31 # Automatically determine the architecture we're building on: … … 35 37 *) export ARCH=$( uname -m ) ;; 36 38 esac 39 fi 40 41 # If the variable PRINT_PACKAGE_NAME is set, then this script will report what 42 # the name of the created package would be, and then exit. This information 43 # could be useful to other scripts. 44 if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then 45 echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz" 46 exit 0 37 47 fi 38 48 … … 51 61 fi 52 62 53 CWD=$(pwd)54 63 TMP=${TMP:-/tmp} 55 64 PKG=$TMP/package-$PKGNAM … … 60 69 cd $TMP 61 70 rm -rf $PKGNAM-$VERSION 62 tar xf $CWD/$PKGNAM-$VERSION.tar. xz || exit 171 tar xf $CWD/$PKGNAM-$VERSION.tar.lz || exit 1 63 72 cd $PKGNAM-$VERSION || exit 1 64 73 … … 106 115 107 116 mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION 108 cp -a COPYING* $PKG/usr/doc/$PKGNAM-$VERSION117 cp -a COPYING* $PKG/usr/doc/$PKGNAM-$VERSION 109 118 110 119 mkdir -p $PKG/install -
Property
mode
changed from
Note: See TracChangeset
for help on using the changeset viewer.