Ignore:
Timestamp:
01/11/19 22:38:23 (6 years ago)
Author:
Edwin Eefting <edwin@datux.nl>
Branches:
master
Children:
834b847
Parents:
6936b89
Message:

iptables upgrade for kernel 4.9

File:
1 edited

Legend:

Unmodified
Added
Removed
  • npl/system/libnftnl/libnftnl.SlackBuild.orig

    • Property mode changed from 100755 to 100644
    r6936b89 r94a6f37  
    1 #!/bin/sh
     1#!/bin/bash
    22
    3 # Copyright 2014  Patrick J. Volkerding, Sebeka, Minnesota, USA
     3# Copyright 2014, 2018  Patrick J. Volkerding, Sebeka, Minnesota, USA
    44# All rights reserved.
    55#
     
    2121#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
    2222
     23cd $(dirname $0) ; CWD=$(pwd)
     24
    2325PKGNAM=libnftnl
    24 VERSION=${VERSION:-$(echo $PKGNAM-*.tar.xz | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
     26VERSION=${VERSION:-$(echo $PKGNAM-*.tar.lz | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
    2527BUILD=${BUILD:-1}
    2628
    27 NUMJOBS=${NUMJOBS:-" -j7 "}
     29NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
    2830
    2931# Automatically determine the architecture we're building on:
     
    3537       *) export ARCH=$( uname -m ) ;;
    3638  esac
     39fi
     40
     41# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
     42# the name of the created package would be, and then exit. This information
     43# could be useful to other scripts.
     44if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
     45  echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
     46  exit 0
    3747fi
    3848
     
    5161fi
    5262
    53 CWD=$(pwd)
    5463TMP=${TMP:-/tmp}
    5564PKG=$TMP/package-$PKGNAM
     
    6069cd $TMP
    6170rm -rf $PKGNAM-$VERSION
    62 tar xf $CWD/$PKGNAM-$VERSION.tar.xz || exit 1
     71tar xf $CWD/$PKGNAM-$VERSION.tar.lz || exit 1
    6372cd $PKGNAM-$VERSION || exit 1
    6473
     
    106115
    107116mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
    108 cp -a COPYING* $PKG/usr/doc/$PKGNAM-$VERSION
     117cp -a COPYING*  $PKG/usr/doc/$PKGNAM-$VERSION
    109118
    110119mkdir -p $PKG/install
Note: See TracChangeset for help on using the changeset viewer.