Ignore:
Timestamp:
06/14/21 10:28:36 (4 years ago)
Author:
Edwin Eefting <edwin@datux.nl>
Branches:
master
Children:
62266ed
Parents:
31fd825
Message:

conntrack_tools and deps

File:
1 edited

Legend:

Unmodified
Added
Removed
  • npl/system/libmnl/libmnl.SlackBuild.orig

    r31fd825 ra87727a  
    1 #!/bin/sh
     1#!/bin/bash
    22
    33# Slackware build script for libmnl
    44
    5 # Copyright 2013  Patrick J. Volkerding, Sebeka, Minnesota, USA
     5# Copyright 2013, 2018  Patrick J. Volkerding, Sebeka, Minnesota, USA
    66# Copyright 2013  Robby Workman, Northport, Alabama, USA
    77# All rights reserved.
     
    2424#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
    2525
     26cd $(dirname $0) ; CWD=$(pwd)
     27
    2628PKGNAM=libmnl
    2729VERSION=${VERSION:-$(echo $PKGNAM-*.tar.xz | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
    28 BUILD=${BUILD:-1}
     30BUILD=${BUILD:-5}
    2931
    30 NUMJOBS=${NUMJOBS:-" -j7 "}
     32NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
    3133
    3234# Automatically determine the architecture we're building on:
    3335if [ -z "$ARCH" ]; then
    3436  case "$( uname -m )" in
    35     i?86) export ARCH=i486 ;;
     37    i?86) export ARCH=i586 ;;
    3638    arm*) export ARCH=arm ;;
    3739    # Unless $ARCH is already set, use uname -m for all other archs:
     
    4042fi
    4143
    42 if [ "$ARCH" = "i486" ]; then
    43   SLKCFLAGS="-O2 -march=i486 -mtune=i686"
     44# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
     45# the name of the created package would be, and then exit. This information
     46# could be useful to other scripts.
     47if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
     48  echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
     49  exit 0
     50fi
     51
     52if [ "$ARCH" = "i586" ]; then
     53  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
    4454  LIBDIRSUFFIX=""
    4555elif [ "$ARCH" = "s390" ]; then
     
    5464fi
    5565
    56 CWD=$(pwd)
    5766TMP=${TMP:-/tmp}
    5867PKG=$TMP/package-$PKGNAM
     
    6978find . \
    7079  \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
    71   -exec chmod 755 {} \; -o \
     80  -exec chmod 755 {} \+ -o \
    7281  \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
    73   -exec chmod 644 {} \;
     82  -exec chmod 644 {} \+
    7483
    7584CFLAGS="$SLKCFLAGS" \
     
    8998
    9099rm -f $PKG/usr/lib${LIBDIRSUFFIX}/*.la
     100
     101# Move the shared library to $PKG/lib${LIBDIRSUFFIX}:
     102mkdir -p $PKG/lib${LIBDIRSUFFIX}
     103( cd $PKG/usr/lib${LIBDIRSUFFIX}
     104  for file in lib*.so.?.* ; do
     105    mv $file ../../lib${LIBDIRSUFFIX}
     106    ln -sf ../../lib${LIBDIRSUFFIX}/$file .
     107  done
     108  cp -a lib*.so.? ../../lib${LIBDIRSUFFIX}
     109)
    91110
    92111find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | \
Note: See TracChangeset for help on using the changeset viewer.