Changeset a87727a for npl/system/libmnl/libmnl.SlackBuild.orig
- Timestamp:
- 06/14/21 10:28:36 (4 years ago)
- Branches:
- master
- Children:
- 62266ed
- Parents:
- 31fd825
- File:
-
- 1 edited
Legend:
- Unmodified
- Added
- Removed
-
npl/system/libmnl/libmnl.SlackBuild.orig
r31fd825 ra87727a 1 #!/bin/ sh1 #!/bin/bash 2 2 3 3 # Slackware build script for libmnl 4 4 5 # Copyright 2013 Patrick J. Volkerding, Sebeka, Minnesota, USA5 # Copyright 2013, 2018 Patrick J. Volkerding, Sebeka, Minnesota, USA 6 6 # Copyright 2013 Robby Workman, Northport, Alabama, USA 7 7 # All rights reserved. … … 24 24 # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. 25 25 26 cd $(dirname $0) ; CWD=$(pwd) 27 26 28 PKGNAM=libmnl 27 29 VERSION=${VERSION:-$(echo $PKGNAM-*.tar.xz | rev | cut -f 3- -d . | cut -f 1 -d - | rev)} 28 BUILD=${BUILD:- 1}30 BUILD=${BUILD:-5} 29 31 30 NUMJOBS=${NUMJOBS:-" -j 7"}32 NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "} 31 33 32 34 # Automatically determine the architecture we're building on: 33 35 if [ -z "$ARCH" ]; then 34 36 case "$( uname -m )" in 35 i?86) export ARCH=i 486 ;;37 i?86) export ARCH=i586 ;; 36 38 arm*) export ARCH=arm ;; 37 39 # Unless $ARCH is already set, use uname -m for all other archs: … … 40 42 fi 41 43 42 if [ "$ARCH" = "i486" ]; then 43 SLKCFLAGS="-O2 -march=i486 -mtune=i686" 44 # If the variable PRINT_PACKAGE_NAME is set, then this script will report what 45 # the name of the created package would be, and then exit. This information 46 # could be useful to other scripts. 47 if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then 48 echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz" 49 exit 0 50 fi 51 52 if [ "$ARCH" = "i586" ]; then 53 SLKCFLAGS="-O2 -march=i586 -mtune=i686" 44 54 LIBDIRSUFFIX="" 45 55 elif [ "$ARCH" = "s390" ]; then … … 54 64 fi 55 65 56 CWD=$(pwd)57 66 TMP=${TMP:-/tmp} 58 67 PKG=$TMP/package-$PKGNAM … … 69 78 find . \ 70 79 \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \ 71 -exec chmod 755 {} \ ;-o \80 -exec chmod 755 {} \+ -o \ 72 81 \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \ 73 -exec chmod 644 {} \ ;82 -exec chmod 644 {} \+ 74 83 75 84 CFLAGS="$SLKCFLAGS" \ … … 89 98 90 99 rm -f $PKG/usr/lib${LIBDIRSUFFIX}/*.la 100 101 # Move the shared library to $PKG/lib${LIBDIRSUFFIX}: 102 mkdir -p $PKG/lib${LIBDIRSUFFIX} 103 ( cd $PKG/usr/lib${LIBDIRSUFFIX} 104 for file in lib*.so.?.* ; do 105 mv $file ../../lib${LIBDIRSUFFIX} 106 ln -sf ../../lib${LIBDIRSUFFIX}/$file . 107 done 108 cp -a lib*.so.? ../../lib${LIBDIRSUFFIX} 109 ) 91 110 92 111 find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | \
Note: See TracChangeset
for help on using the changeset viewer.