Ignore:
Timestamp:
09/30/19 19:59:45 (6 years ago)
Author:
Edwin Eefting <edwin@datux.nl>
Branches:
master
Children:
9befa48
Parents:
42fa616
Message:

update to libreswan 3.29

File:
1 edited

Legend:

Unmodified
Added
Removed
  • npl/overig/mozilla_nss/mozilla-nss.SlackBuild.orig

    r42fa616 rac00c8f  
    1 #!/bin/sh
     1#!/bin/bash
    22# Copyright 2005, 2006, 2008, 2009, 2010, 2012  Eric Hameleers, Eindhoven, NL
    3 # Copyright 2013, 2014, 2015  Patrick J. Volkerding, Sebeka, MN, USA
     3# Copyright 2013, 2014, 2015, 2017, 2018  Patrick J. Volkerding, Sebeka, MN, USA
    44# All rights reserved.
    55#
     
    2323# -----------------------------------------------------------------------------
    2424
     25cd $(dirname $0) ; CWD=$(pwd)
     26
    2527PKGNAM=mozilla-nss
    2628SRCNAM=nss
    27 VERSION=${VERSION:-3.23}
    28 NSPR=${NSPR:-4.12}
     29VERSION=${VERSION:-3.46}
     30NSPR=${NSPR:-4.22}
    2931BUILD=${BUILD:-1}
    3032
     
    3941    *)       export ARCH=$MARCH ;;
    4042  esac
     43fi
     44
     45# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
     46# the name of the created package would be, and then exit. This information
     47# could be useful to other scripts.
     48if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
     49  echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
     50  exit 0
    4151fi
    4252
     
    5666fi
    5767
    58 CWD=$(pwd)
    5968TMP=${TMP:-/tmp}
    6069PKG=$TMP/package-$PKGNAM
    6170
    6271# Seems parallel build does not work with this.
    63 #NUMJOBS=${NUMJOBS:-" -j7 "}
     72#NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
    6473
    6574rm -rf $PKG
     
    6978rm -rf nss-${VERSION}
    7079rm -rf nspr-${NSPR}
    71 tar xvf $CWD/nss-$VERSION.tar.?z* || exit 1
     80tar xvf $CWD/nss-$VERSION.tar.?z || exit 1
    7281cd nss-$VERSION
    73 tar xvf $CWD/nspr-$NSPR.tar.?z* || exit 1
     82tar xvf $CWD/nspr-$NSPR.tar.?z || exit 1
    7483mv nspr*/nspr .
     84
     85# -Werror is problematic with gcc7:
     86sed -i "s|\ -Werror| |" nss/coreconf/Werror.mk || exit 1
    7587
    7688# Make sure ownerships and permissions are sane:
     
    92104cd nss
    93105  # Seems parallel build does not work with this.
    94   #make $NUMJOBS nss_build_all export
    95   make nss_build_all export
     106  #make $NUMJOBS nss_build_all export || exit 1
     107  make nss_build_all export || exit 1
    96108cd -
    97109
Note: See TracChangeset for help on using the changeset viewer.