Changeset ac00c8f for npl/overig/mozilla_nss/mozilla-nss.SlackBuild.orig
- Timestamp:
- 09/30/19 19:59:45 (6 years ago)
- Branches:
- master
- Children:
- 9befa48
- Parents:
- 42fa616
- File:
-
- 1 edited
Legend:
- Unmodified
- Added
- Removed
-
npl/overig/mozilla_nss/mozilla-nss.SlackBuild.orig
r42fa616 rac00c8f 1 #!/bin/ sh1 #!/bin/bash 2 2 # Copyright 2005, 2006, 2008, 2009, 2010, 2012 Eric Hameleers, Eindhoven, NL 3 # Copyright 2013, 2014, 2015 Patrick J. Volkerding, Sebeka, MN, USA3 # Copyright 2013, 2014, 2015, 2017, 2018 Patrick J. Volkerding, Sebeka, MN, USA 4 4 # All rights reserved. 5 5 # … … 23 23 # ----------------------------------------------------------------------------- 24 24 25 cd $(dirname $0) ; CWD=$(pwd) 26 25 27 PKGNAM=mozilla-nss 26 28 SRCNAM=nss 27 VERSION=${VERSION:-3. 23}28 NSPR=${NSPR:-4. 12}29 VERSION=${VERSION:-3.46} 30 NSPR=${NSPR:-4.22} 29 31 BUILD=${BUILD:-1} 30 32 … … 39 41 *) export ARCH=$MARCH ;; 40 42 esac 43 fi 44 45 # If the variable PRINT_PACKAGE_NAME is set, then this script will report what 46 # the name of the created package would be, and then exit. This information 47 # could be useful to other scripts. 48 if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then 49 echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz" 50 exit 0 41 51 fi 42 52 … … 56 66 fi 57 67 58 CWD=$(pwd)59 68 TMP=${TMP:-/tmp} 60 69 PKG=$TMP/package-$PKGNAM 61 70 62 71 # Seems parallel build does not work with this. 63 #NUMJOBS=${NUMJOBS:-" -j 7"}72 #NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "} 64 73 65 74 rm -rf $PKG … … 69 78 rm -rf nss-${VERSION} 70 79 rm -rf nspr-${NSPR} 71 tar xvf $CWD/nss-$VERSION.tar.?z *|| exit 180 tar xvf $CWD/nss-$VERSION.tar.?z || exit 1 72 81 cd nss-$VERSION 73 tar xvf $CWD/nspr-$NSPR.tar.?z *|| exit 182 tar xvf $CWD/nspr-$NSPR.tar.?z || exit 1 74 83 mv nspr*/nspr . 84 85 # -Werror is problematic with gcc7: 86 sed -i "s|\ -Werror| |" nss/coreconf/Werror.mk || exit 1 75 87 76 88 # Make sure ownerships and permissions are sane: … … 92 104 cd nss 93 105 # Seems parallel build does not work with this. 94 #make $NUMJOBS nss_build_all export 95 make nss_build_all export 106 #make $NUMJOBS nss_build_all export || exit 1 107 make nss_build_all export || exit 1 96 108 cd - 97 109
Note: See TracChangeset
for help on using the changeset viewer.