Ignore:
Timestamp:
11/21/17 15:41:07 (7 years ago)
Author:
Edwin Eefting <edwin@datux.nl>
Branches:
master, perl-5.22
Children:
f560c0b
Parents:
e248cf2 (diff), 21dd3b8 (diff)
Note: this is a merge changeset, the changes displayed below correspond to the merge itself.
Use the (diff) links above to see all the changes relative to each parent.
Message:

Merge commit '21dd3b89978a441302efa0a2c7d9a6cc59ec177a'

File:
1 edited

Legend:

Unmodified
Added
Removed
  • npl/internetserver/poptop_pptpd/poptop_pptpd.SlackBuild

    re248cf2 rd6ed36a  
    11#!/bin/sh
     2#DEP:ppp
     3
    24
    35CWD=`pwd`
     
    79mkdir -p $PKG
    810
    9 VERSION=1.3.4
     11VERSION=1.4.0
    1012ARCH=${ARCH:-i486}
    1113BUILD=1DatuX
     
    1416rm -rf *
    1517
    16 tar xzvf $CWD/pptpd-1.3.4.tar.gz
    17 cd pptpd-1.3.4
     18tar xzvf $CWD/pptpd-$VERSION.tar.gz
     19cd pptpd-$VERSION
    1820./configure --with-libwrap \
    1921    --enable-bcrelay \
     
    2426    --libdir=/usr/lib \
    2527    --libexecdir=/usr/sbin || exit 1
    26      
     28
    2729make -j 1 || exit 1
    2830make -j 1 install DESTDIR=$PKG || exit 1
     
    4345cat << EOF > $PKG/service/pptpd/run
    4446#!/bin/bash
     47modprobe pptp
    4548exec pptpd -f -c /home/system/pptpd/pptpd.conf
    4649EOF
    47 chmod +x $PKG/service/pptpd/run 
     50chmod +x $PKG/service/pptpd/run
    4851
    4952#etc config files fixxen
     
    6063makepkg -l y -c n $CWD/$NAME.pkg > /dev/null &&
    6164echo $VERSION > $CWD/$NAME.version &&
    62 arch > $CWD/$NAME.arch 
     65arch > $CWD/$NAME.arch
Note: See TracChangeset for help on using the changeset viewer.