Changeset f9ce31e for npl/system/openssl/openssl.SlackBuild.orig
- Timestamp:
- 09/06/18 18:23:18 (7 years ago)
- Branches:
- master, perl-5.22
- Children:
- 548499b
- Parents:
- 6a847ef
- File:
-
- 1 edited
Legend:
- Unmodified
- Added
- Removed
-
npl/system/openssl/openssl.SlackBuild.orig
-
Property
mode
changed from
100644
to100755
r6a847ef rf9ce31e 70 70 find . -name "*.pod" -exec sed -i "s/^\=item \([0-9]\)\(\ \|$\)/\=item C<\1>/g" {} \; 71 71 72 # Use .so.1, not .so.1.0.0: 73 sed -i "s/soname=\$\$SHLIB\$\$SHLIB_SOVER\$\$SHLIB_SUFFIX/soname=\$\$SHLIB.1/g" Makefile.shared 72 ## For openssl-1.1.x, don't try to change the soname. 73 ## Use .so.1, not .so.1.0.0: 74 #sed -i "s/soname=\$\$SHLIB\$\$SHLIB_SOVER\$\$SHLIB_SUFFIX/soname=\$\$SHLIB.1/g" Makefile.shared 74 75 75 76 if [ "$ARCH" = "i586" ]; then … … 90 91 # what they were compiled against, whether or not the ABI has changed. 91 92 # 92 # So, we will use the OPENSSL_VERSION_NUMBER from openssl-1. 0.2eunless ABI93 # So, we will use the OPENSSL_VERSION_NUMBER from openssl-1.1.0h unless ABI 93 94 # breakage forces it to change. Yes, we're finally using this old trick. :) 94 sed -i "s/#define OPENSSL_VERSION_NUMBER.*/\/* Use 0x10 00205fL (1.0.2e) below to avoid pointlessly breaking the ABI *\/\n#define OPENSSL_VERSION_NUMBER 0x1000205fL/g" crypto/opensslv.h || exit 195 sed -i "s/#define OPENSSL_VERSION_NUMBER.*/\/* Use 0x1010008fL (1.1.0h) below to avoid pointlessly breaking the ABI *\/\n#define OPENSSL_VERSION_NUMBER 0x1000205fL/g" include/openssl/opensslv.h || exit 1 95 96 96 97 chown -R root:root . 97 98 mkdir -p $PKG1/usr/doc/openssl-$VERSION 98 cp -a CHANGES CHANGES.SSLeay FAQ INSTALL INSTALL.MacOS INSTALL.VMS INSTALL.W32 \ 99 LICENSE NEWS README README.ENGINE doc $PKG1/usr/doc/openssl-$VERSION 99 cp -a ACKNOWLEDGEMENTS AUTHORS CHANGES* CONTRIBUTING FAQ INSTALL* \ 100 LICENSE* NEWS NOTES* README* doc \ 101 $PKG1/usr/doc/openssl-$VERSION 100 102 find $PKG1/usr/doc/openssl-$VERSION -type d -exec chmod 755 {} \; 101 103 find $PKG1/usr/doc/openssl-$VERSION -type f -exec chmod 644 {} \; … … 113 115 # MDC-2: 4,908,861 2007-03-13, not included. 114 116 # IDEA: 5,214,703 2010-05-25, not included. 115 # RC5: 5,724,428 2015-03-03, not included.116 117 # 117 118 # Although all of the above are expired, it's still probably … … 122 123 --prefix=/usr \ 123 124 --openssldir=/etc/ssl \ 125 zlib \ 126 enable-camellia \ 127 enable-seed \ 128 enable-rfc3779 \ 129 enable-cms \ 130 enable-md2 \ 131 enable-rc5 \ 132 enable-ssl3 \ 133 enable-ssl3-method \ 134 no-weak-ssl-ciphers \ 124 135 no-mdc2 \ 136 no-ec2m \ 125 137 no-idea \ 126 no-rc5 \127 138 no-sse2 \ 128 no-ssl2 \129 no-weak-ssl-ciphers \130 139 shared 131 140 … … 134 143 make $NUMJOBS || make || exit 1 135 144 136 make test -j1 || exit 1 137 138 make install INSTALL_PREFIX=$PKG1 || exit 1 145 make install DESTDIR=$PKG1 || exit 1 146 147 # No thanks on the static libraries: 148 rm -f $PKG1/usr/lib${LIBDIRSUFFIX}/*.a 149 150 # No thanks on manpages duplicated as html: 151 rm -rf $PKG1/usr/share/doc 139 152 140 153 # Make the .so.? library symlinks: … … 149 162 mv $file ../../lib${LIBDIRSUFFIX} 150 163 ln -sf ../../lib${LIBDIRSUFFIX}/$file . 151 done 152 cp -a lib*.so.? ../../lib${LIBDIRSUFFIX}164 done 165 # cp -a lib*.so.? ../../lib${LIBDIRSUFFIX} 153 166 ) 154 167 … … 158 171 chmod 755 $PKG1/etc/cron.daily/certwatch.new 159 172 173 # Make config file non-clobber: 160 174 mv $PKG1/etc/ssl/openssl.cnf $PKG1/etc/ssl/openssl.cnf.new 175 176 # Remove duplicate config file: 177 rm -f $PKG1/etc/ssl/openssl.cnf.dist 161 178 162 179 ( cd $PKG1 … … 165 182 ) 166 183 167 mv $PKG1/etc/ssl/man $PKG1/usr 184 # Relocate the manpages: 185 mv $PKG1/usr/share/man $PKG1/usr 186 rmdir $PKG1/usr/share 187 168 188 # Fix manpage name collisions, and relink anything that linked to the old name: 169 189 ( cd $PKG1/usr/man/man1 … … 174 194 rm -f $file 175 195 ln -sf ssl_passwd.1 $file 176 fi177 fi178 done )179 ( cd $PKG1/usr/man/man3180 mv rand.3 ssl_rand.3181 for file in *.3 ; do182 if [ -L $file ]; then183 if [ "$(readlink $file)" = "rand.3" ]; then184 rm -f $file185 ln -sf ssl_rand.3 $file186 fi187 fi188 done )189 ( cd $PKG1/usr/man/man3190 mv err.3 ssl_err.3191 for file in *.3 ; do192 if [ -L $file ]; then193 if [ "$(readlink $file)" = "err.3" ]; then194 rm -f $file195 ln -sf ssl_err.3 $file196 196 fi 197 197 fi … … 213 213 fi 214 214 215 # If there's an openssl 0 directory, then build openssl-0 shared libraries for215 # If there's an openssl1 directory, then build openssl-1.0 shared libraries for 216 216 # compatibility with programs linked to those: 217 if [ -d $CWD/openssl 0]; then218 ( cd $CWD/openssl 0219 ./openssl 0.build || exit 1217 if [ -d $CWD/openssl1 ]; then 218 ( cd $CWD/openssl1 219 ./openssl1.build || exit 1 220 220 ) || exit 1 221 221 # Don't put these in the openssl package... openssl-solibs is enough. 222 222 #mkdir -p $PKG1/lib${LIBDIRSUFFIX} 223 #cp -a $TMP/package-openssl 0/usr/lib/lib*.so.?.?.? $PKG1/lib${LIBDIRSUFFIX}223 #cp -a $TMP/package-openssl1/usr/lib/lib*.so.?.?.? $PKG1/lib${LIBDIRSUFFIX} 224 224 #( cd $PKG1/lib${LIBDIRSUFFIX} ; ldconfig -l lib*.so.?.?.? ) 225 225 mkdir -p $PKG2/lib${LIBDIRSUFFIX} 226 cp -a $TMP/package-openssl 0/usr/lib/lib*.so.?.?.? $PKG2/lib${LIBDIRSUFFIX}226 cp -a $TMP/package-openssl1/usr/lib${LIBDIRSUFFIX}/lib*.so.?.?.? $PKG2/lib${LIBDIRSUFFIX} 227 227 ( cd $PKG2/lib${LIBDIRSUFFIX} ; ldconfig -l lib*.so.?.?.? ) 228 228 fi … … 244 244 mkdir -p $PKG2/usr/doc/openssl-$VERSION 245 245 ( cd $TMP/openssl-$VERSION 246 cp -a CHANGES CHANGES.SSLeay FAQ INSTALL INSTALL.MacOS INSTALL.VMS INSTALL.W32\247 LICENSE NEWS README README.ENGINE$PKG2/usr/doc/openssl-$VERSION246 cp -a ACKNOWLEDGEMENTS AUTHORS CHANGES* CONTRIBUTING FAQ INSTALL* \ 247 LICENSE* NEWS NOTES* README* $PKG2/usr/doc/openssl-$VERSION 248 248 # If there's a CHANGES file, installing at least part of the recent history 249 249 # is useful, but don't let it get totally out of control: -
Property
mode
changed from
Note: See TracChangeset
for help on using the changeset viewer.