Ignore:
Timestamp:
09/06/18 18:23:18 (7 years ago)
Author:
Edwin Eefting <edwin@datux.nl>
Branches:
master, perl-5.22
Children:
548499b
Parents:
6a847ef
Message:

updated to openssl 1.1.x, added ca-certificates. cleanup

File:
1 edited

Legend:

Unmodified
Added
Removed
  • npl/system/openssl/openssl.SlackBuild.orig

    • Property mode changed from 100644 to 100755
    r6a847ef rf9ce31e  
    7070find . -name "*.pod" -exec sed -i "s/^\=item \([0-9]\)\(\ \|$\)/\=item C<\1>/g" {} \;
    7171
    72 # Use .so.1, not .so.1.0.0:
    73 sed -i "s/soname=\$\$SHLIB\$\$SHLIB_SOVER\$\$SHLIB_SUFFIX/soname=\$\$SHLIB.1/g" Makefile.shared
     72## For openssl-1.1.x, don't try to change the soname.
     73## Use .so.1, not .so.1.0.0:
     74#sed -i "s/soname=\$\$SHLIB\$\$SHLIB_SOVER\$\$SHLIB_SUFFIX/soname=\$\$SHLIB.1/g" Makefile.shared
    7475
    7576if [ "$ARCH" = "i586" ]; then
     
    9091# what they were compiled against, whether or not the ABI has changed.
    9192#
    92 # So, we will use the OPENSSL_VERSION_NUMBER from openssl-1.0.2e unless ABI
     93# So, we will use the OPENSSL_VERSION_NUMBER from openssl-1.1.0h unless ABI
    9394# breakage forces it to change.  Yes, we're finally using this old trick.  :)
    94 sed -i "s/#define OPENSSL_VERSION_NUMBER.*/\/* Use 0x1000205fL (1.0.2e) below to avoid pointlessly breaking the ABI *\/\n#define OPENSSL_VERSION_NUMBER 0x1000205fL/g" crypto/opensslv.h || exit 1
     95sed -i "s/#define OPENSSL_VERSION_NUMBER.*/\/* Use 0x1010008fL (1.1.0h) below to avoid pointlessly breaking the ABI *\/\n#define OPENSSL_VERSION_NUMBER 0x1000205fL/g" include/openssl/opensslv.h || exit 1
    9596
    9697chown -R root:root .
    9798mkdir -p $PKG1/usr/doc/openssl-$VERSION
    98 cp -a CHANGES CHANGES.SSLeay FAQ INSTALL INSTALL.MacOS INSTALL.VMS INSTALL.W32 \
    99   LICENSE NEWS README README.ENGINE doc $PKG1/usr/doc/openssl-$VERSION
     99cp -a ACKNOWLEDGEMENTS AUTHORS CHANGES* CONTRIBUTING FAQ INSTALL* \
     100  LICENSE* NEWS NOTES* README* doc \
     101  $PKG1/usr/doc/openssl-$VERSION
    100102find $PKG1/usr/doc/openssl-$VERSION -type d -exec chmod 755 {} \;
    101103find $PKG1/usr/doc/openssl-$VERSION -type f -exec chmod 644 {} \;
     
    113115# MDC-2: 4,908,861  2007-03-13, not included.
    114116# IDEA:  5,214,703  2010-05-25, not included.
    115 # RC5:   5,724,428  2015-03-03, not included.
    116117#
    117118# Although all of the above are expired, it's still probably
     
    122123 --prefix=/usr \
    123124 --openssldir=/etc/ssl \
     125 zlib \
     126 enable-camellia \
     127 enable-seed \
     128 enable-rfc3779 \
     129 enable-cms \
     130 enable-md2 \
     131 enable-rc5 \
     132 enable-ssl3 \
     133 enable-ssl3-method \
     134 no-weak-ssl-ciphers \
    124135 no-mdc2 \
     136 no-ec2m \
    125137 no-idea \
    126  no-rc5 \
    127138 no-sse2 \
    128  no-ssl2 \
    129  no-weak-ssl-ciphers \
    130139 shared
    131140
     
    134143make $NUMJOBS || make || exit 1
    135144
    136 make test -j1 || exit 1
    137 
    138 make install INSTALL_PREFIX=$PKG1 || exit 1
     145make install DESTDIR=$PKG1 || exit 1
     146
     147# No thanks on the static libraries:
     148rm -f $PKG1/usr/lib${LIBDIRSUFFIX}/*.a
     149
     150# No thanks on manpages duplicated as html:
     151rm -rf $PKG1/usr/share/doc
    139152
    140153# Make the .so.? library symlinks:
     
    149162    mv $file ../../lib${LIBDIRSUFFIX}
    150163    ln -sf ../../lib${LIBDIRSUFFIX}/$file .
    151   done 
    152   cp -a lib*.so.? ../../lib${LIBDIRSUFFIX}
     164  done
     165  # cp -a lib*.so.? ../../lib${LIBDIRSUFFIX}
    153166)
    154167
     
    158171chmod 755 $PKG1/etc/cron.daily/certwatch.new
    159172
     173# Make config file non-clobber:
    160174mv $PKG1/etc/ssl/openssl.cnf $PKG1/etc/ssl/openssl.cnf.new
     175
     176# Remove duplicate config file:
     177rm -f $PKG1/etc/ssl/openssl.cnf.dist
    161178
    162179( cd $PKG1
     
    165182)
    166183
    167 mv $PKG1/etc/ssl/man $PKG1/usr
     184# Relocate the manpages:
     185mv $PKG1/usr/share/man $PKG1/usr
     186rmdir $PKG1/usr/share
     187
    168188# Fix manpage name collisions, and relink anything that linked to the old name:
    169189( cd $PKG1/usr/man/man1
     
    174194        rm -f $file
    175195        ln -sf ssl_passwd.1 $file
    176       fi
    177     fi
    178   done )
    179 ( cd $PKG1/usr/man/man3
    180   mv rand.3 ssl_rand.3
    181   for file in *.3 ; do
    182     if [ -L $file ]; then
    183       if [ "$(readlink $file)" = "rand.3" ]; then
    184         rm -f $file
    185         ln -sf ssl_rand.3 $file
    186       fi
    187     fi
    188   done )
    189 ( cd $PKG1/usr/man/man3
    190   mv err.3 ssl_err.3
    191   for file in *.3 ; do
    192     if [ -L $file ]; then
    193       if [ "$(readlink $file)" = "err.3" ]; then
    194         rm -f $file
    195         ln -sf ssl_err.3 $file
    196196      fi
    197197    fi
     
    213213fi
    214214
    215 # If there's an openssl0 directory, then build openssl-0 shared libraries for
     215# If there's an openssl1 directory, then build openssl-1.0 shared libraries for
    216216# compatibility with programs linked to those:
    217 if [ -d $CWD/openssl0 ]; then
    218   ( cd $CWD/openssl0
    219     ./openssl0.build || exit 1
     217if [ -d $CWD/openssl1 ]; then
     218  ( cd $CWD/openssl1
     219    ./openssl1.build || exit 1
    220220  ) || exit 1
    221221  # Don't put these in the openssl package...  openssl-solibs is enough.
    222222  #mkdir -p $PKG1/lib${LIBDIRSUFFIX}
    223   #cp -a $TMP/package-openssl0/usr/lib/lib*.so.?.?.? $PKG1/lib${LIBDIRSUFFIX}
     223  #cp -a $TMP/package-openssl1/usr/lib/lib*.so.?.?.? $PKG1/lib${LIBDIRSUFFIX}
    224224  #( cd $PKG1/lib${LIBDIRSUFFIX} ; ldconfig -l lib*.so.?.?.? )
    225225  mkdir -p $PKG2/lib${LIBDIRSUFFIX}
    226   cp -a $TMP/package-openssl0/usr/lib/lib*.so.?.?.? $PKG2/lib${LIBDIRSUFFIX}
     226  cp -a $TMP/package-openssl1/usr/lib${LIBDIRSUFFIX}/lib*.so.?.?.? $PKG2/lib${LIBDIRSUFFIX}
    227227  ( cd $PKG2/lib${LIBDIRSUFFIX} ; ldconfig -l lib*.so.?.?.? )
    228228fi
     
    244244mkdir -p $PKG2/usr/doc/openssl-$VERSION
    245245( cd $TMP/openssl-$VERSION
    246   cp -a CHANGES CHANGES.SSLeay FAQ INSTALL INSTALL.MacOS INSTALL.VMS INSTALL.W32 \
    247   LICENSE NEWS README README.ENGINE $PKG2/usr/doc/openssl-$VERSION
     246  cp -a ACKNOWLEDGEMENTS AUTHORS CHANGES* CONTRIBUTING FAQ INSTALL* \
     247  LICENSE* NEWS NOTES* README* $PKG2/usr/doc/openssl-$VERSION
    248248  # If there's a CHANGES file, installing at least part of the recent history
    249249  # is useful, but don't let it get totally out of control:
Note: See TracChangeset for help on using the changeset viewer.