Ignore:
Timestamp:
11/29/21 12:16:54 (3 years ago)
Author:
Edwin Eefting <edwin@datux.nl>
Branches:
master
Children:
439f083
Parents:
7c410f9
Message:

update curl, acme (certbot/letsencrypt) and root ca's

File:
1 edited

Legend:

Unmodified
Added
Removed
  • npl/system/ca_certificates/ca-certificates.SlackBuild.orig

    r7c410f9 r105afb5  
    1 #!/bin/sh
     1#!/bin/bash
    22
    33# Slackware build script for ca-certificates
    44
    55# Copyright 2009,2011  Robby Workman  Northport, AL, USA
    6 # Copyright 2012, 2013, 2015, 2016  Patrick J. Volkerding, Sebeka, MN, USA
     6# Copyright 2012, 2013, 2015, 2016, 2018  Patrick J. Volkerding, Sebeka, MN, USA
    77# All rights reserved.
    88#
     
    2424# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
    2525
     26cd $(dirname $0) ; CWD=$(pwd)
     27
    2628PKGNAM=ca-certificates
    27 VERSION=${VERSION:-20161130}
     29VERSION=${VERSION:-$(echo certdata-*.txt.xz | cut -f 2 -d - | cut -f 1 -d .)}
    2830ARCH=noarch
    2931BUILD=${BUILD:-1_slack14.2}
    3032
    31 TARVERSION=${VERSION}+nmu1
     33# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
     34# the name of the created package would be, and then exit. This information
     35# could be useful to other scripts.
     36if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
     37  echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
     38  exit 0
     39fi
    3240
    33 CWD=$(pwd)
     41TARVERSION=${VERSION}
     42
    3443TMP=${TMP:-/tmp}
    3544PKG=$TMP/package-$PKGNAM
     
    3948cd $TMP
    4049
    41 # Need both $PKGNAM and $PKGNAM-$VERSION since upstream can't decide how
    42 # to package their tarball:
    43 rm -rf $PKGNAM $PKGNAM-$VERSION
     50rm -rf $PKGNAM
    4451
    4552# Extract the tarball:
    46 tar xvf $CWD/${PKGNAM}_$TARVERSION.tar.?z || exit 1
     53tar xvf $CWD/${PKGNAM}.tar.?z || exit 1
    4754
    48 # Again, both $PKGNAM and $PKGNAM-$VERSION are needed here:
    49 cd $PKGNAM-$VERSION || cd $PKGNAM || exit 1
     55cd $PKGNAM || exit 1
    5056
    5157chown -R root:root .
     
    5662 -exec chmod 644 {} \;
    5763
    58 # Obsolete?
    59 #zcat $CWD/patches/fixup_DESTDIR.diff.gz | patch -p1 || exit 1
     64# Remove incompatible command operators used to call 'run-parts':
     65zcat $CWD/fixup_update-ca-certificates.diff.gz | patch -p1 || exit 1
    6066
    61 # Remove incompatible command operators used to call 'run-parts':
    62 zcat $CWD/patches/fixup_update-ca-certificates.diff.gz | patch -p1 || exit 1
     67# Use "c_rehash" rather than "openssl rehash". They act mostly the same, but
     68# the openssl builtin is not available on older versions of Slackware, while
     69# c_rehash will always be there.
     70zcat $CWD/update-ca-certificates.c_rehash.diff.gz | patch -p1 || exit 1
     71
     72# Update to certdata.txt from $CWD:
     73xzcat $CWD/certdata-${VERSION}.txt.xz > mozilla/certdata.txt
    6374
    6475make || exit 1
    6576make install DESTDIR=$PKG || exit 1
    6677
     78# Remove expired certificate:
     79if [ -r $PKG//usr/share/ca-certificates/mozilla/DST_Root_CA_X3.crt ]; then
     80  rm -f $PKG//usr/share/ca-certificates/mozilla/DST_Root_CA_X3.crt
     81fi
     82
    6783mkdir -p $PKG/etc/ca-certificates/update.d
    6884printf "# Automatically generated by $PKGNAM-$VERSION \n#\n" \
    69   > $PKG/etc/ca-certificates.conf.new
     85  > $PKG/etc/ca-certificates.conf
    7086( cd $PKG/usr/share/ca-certificates
    7187  find . -name '*.crt' | sort | cut -b3-
    72 ) >> $PKG/etc/ca-certificates.conf.new
     88) >> $PKG/etc/ca-certificates.conf
    7389
    7490mkdir -p $PKG/usr/man/man8
     
    7793
    7894mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
    79 mv debian/NEWS debian/NEWS.Debian
    80 cp -a debian/NEWS.Debian debian/README.Debian $PKG/usr/doc/$PKGNAM-$VERSION
     95cp -a docs/* $PKG/usr/doc/$PKGNAM-$VERSION
    8196
    8297mkdir -p $PKG/var/log/setup
Note: See TracChangeset for help on using the changeset viewer.