Ignore:
Timestamp:
09/20/18 18:43:08 (7 years ago)
Author:
Edwin Eefting <edwin@datux.nl>
Branches:
master, perl-5.22
Children:
c9755c3
Parents:
c9ea2dd
Message:

revert to latest open ssh 1.0 (1.0.2p). not all services support 1.1 yet

File:
1 edited

Legend:

Unmodified
Added
Removed
  • npl/system/openssl/openssl.SlackBuild.orig

    rc9ea2dd r4933918  
    1 #!/bin/bash
     1#!/bin/sh
    22
    33# Copyright 2000 BSDi, Inc. Concord, CA, USA
    44# Copyright 2001, 2002 Slackware Linux, Inc.  Concord, CA, USA
    5 # Copyright 2005, 2006, 2007, 2008, 2009, 2010, 2011, 2012, 2013, 2014, 2015, 2018  Patrick J. Volkerding, Sebeka, MN, USA
     5# Copyright 2005, 2006, 2007, 2008, 2009, 2010, 2011, 2012, 2013, 2014, 2015  Patrick J. Volkerding, Sebeka, MN, USA
    66# All rights reserved.
    77#
     
    2323#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
    2424
     25
    2526# Set initial variables:
    26 cd $(dirname $0) ; CWD=$(pwd)
     27CWD=$(pwd)
    2728TMP=${TMP:-/tmp}
    2829
    29 PKGNAM=openssl
    3030VERSION=${VERSION:-$(echo openssl-*.tar.gz | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
    31 BUILD=${BUILD:-2}
     31BUILD=${BUILD:-1_slack14.2}
    3232
    3333# Automatically determine the architecture we're building on:
     
    4646NAME2=openssl-solibs-$VERSION-$ARCH-$BUILD
    4747
    48 # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
    49 # the name of the created package would be, and then exit. This information
    50 # could be useful to other scripts.
    51 if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
    52   echo "${NAME1}.txz"
    53   echo "${NAME2}.txz"
    54   exit 0
    55 fi
    56 
    5748# Parallel build doesn't link properly.
    5849#NUMJOBS=${NUMJOBS:--j6}
     
    7061find . -name "*.pod" -exec sed -i "s/^\=item \([0-9]\)\(\ \|$\)/\=item C<\1>/g" {} \;
    7162
    72 ## For openssl-1.1.x, don't try to change the soname.
    73 ## Use .so.1, not .so.1.0.0:
    74 #sed -i "s/soname=\$\$SHLIB\$\$SHLIB_SOVER\$\$SHLIB_SUFFIX/soname=\$\$SHLIB.1/g" Makefile.shared
     63# Use .so.1, not .so.1.0.0:
     64sed -i "s/soname=\$\$SHLIB\$\$SHLIB_SOVER\$\$SHLIB_SUFFIX/soname=\$\$SHLIB.1/g" Makefile.shared
    7565
    7666if [ "$ARCH" = "i586" ]; then
     
    9181# what they were compiled against, whether or not the ABI has changed.
    9282#
    93 # So, we will use the OPENSSL_VERSION_NUMBER from openssl-1.1.0h unless ABI
     83# So, we will use the OPENSSL_VERSION_NUMBER from openssl-1.0.2e unless ABI
    9484# breakage forces it to change.  Yes, we're finally using this old trick.  :)
    95 sed -i "s/#define OPENSSL_VERSION_NUMBER.*/\/* Use 0x1010008fL (1.1.0h) below to avoid pointlessly breaking the ABI *\/\n#define OPENSSL_VERSION_NUMBER 0x1000205fL/g" include/openssl/opensslv.h || exit 1
     85sed -i "s/#define OPENSSL_VERSION_NUMBER.*/\/* Use 0x1000205fL (1.0.2e) below to avoid pointlessly breaking the ABI *\/\n#define OPENSSL_VERSION_NUMBER 0x1000205fL/g" crypto/opensslv.h || exit 1
    9686
    9787chown -R root:root .
    9888mkdir -p $PKG1/usr/doc/openssl-$VERSION
    99 cp -a ACKNOWLEDGEMENTS AUTHORS CHANGES* CONTRIBUTING FAQ INSTALL* \
    100   LICENSE* NEWS NOTES* README* doc \
    101   $PKG1/usr/doc/openssl-$VERSION
     89cp -a CHANGES CHANGES.SSLeay FAQ INSTALL INSTALL.MacOS INSTALL.VMS INSTALL.W32 \
     90  LICENSE NEWS README README.ENGINE doc $PKG1/usr/doc/openssl-$VERSION
    10291find $PKG1/usr/doc/openssl-$VERSION -type d -exec chmod 755 {} \;
    10392find $PKG1/usr/doc/openssl-$VERSION -type f -exec chmod 644 {} \;
     
    115104# MDC-2: 4,908,861  2007-03-13, not included.
    116105# IDEA:  5,214,703  2010-05-25, not included.
     106# RC5:   5,724,428  2015-03-03, not included.
    117107#
    118108# Although all of the above are expired, it's still probably
     
    123113 --prefix=/usr \
    124114 --openssldir=/etc/ssl \
    125  zlib \
    126  enable-camellia \
    127  enable-seed \
    128  enable-rfc3779 \
    129  enable-cms \
    130  enable-md2 \
    131  enable-rc5 \
    132  enable-ssl3 \
    133  enable-ssl3-method \
     115 no-mdc2 \
     116 no-idea \
     117 no-rc5 \
     118 no-sse2 \
     119 no-ssl2 \
    134120 no-weak-ssl-ciphers \
    135  no-mdc2 \
    136  no-ec2m \
    137  no-idea \
    138  no-sse2 \
    139121 shared
    140122
     
    143125make $NUMJOBS || make || exit 1
    144126
    145 make install DESTDIR=$PKG1 || exit 1
    146 
    147 # No thanks on the static libraries:
    148 rm -f $PKG1/usr/lib${LIBDIRSUFFIX}/*.a
    149 
    150 # No thanks on manpages duplicated as html:
    151 rm -rf $PKG1/usr/share/doc
     127make install INSTALL_PREFIX=$PKG1 || exit 1
    152128
    153129# Make the .so.? library symlinks:
     
    162138    mv $file ../../lib${LIBDIRSUFFIX}
    163139    ln -sf ../../lib${LIBDIRSUFFIX}/$file .
    164   done
    165   # cp -a lib*.so.? ../../lib${LIBDIRSUFFIX}
     140  done 
     141  cp -a lib*.so.? ../../lib${LIBDIRSUFFIX}
    166142)
    167143
     
    171147chmod 755 $PKG1/etc/cron.daily/certwatch.new
    172148
    173 # Make config file non-clobber:
    174149mv $PKG1/etc/ssl/openssl.cnf $PKG1/etc/ssl/openssl.cnf.new
    175 
    176 # Remove duplicate config file:
    177 rm -f $PKG1/etc/ssl/openssl.cnf.dist
    178150
    179151( cd $PKG1
     
    182154)
    183155
    184 # Relocate the manpages:
    185 mv $PKG1/usr/share/man $PKG1/usr
    186 rmdir $PKG1/usr/share
    187 
    188 # Fix manpage name collisions, and relink anything that linked to the old name:
    189 ( cd $PKG1/usr/man/man1
    190   mv passwd.1 ssl_passwd.1
    191   for file in *.1 ; do
    192     if [ -L $file ]; then
    193       if [ "$(readlink $file)" = "passwd.1" ]; then
    194         rm -f $file
    195         ln -sf ssl_passwd.1 $file
    196       fi
    197     fi
    198   done )
    199 
     156mv $PKG1/etc/ssl/man $PKG1/usr
     157( cd $PKG1/usr/man/man1 ; mv passwd.1 ssl_passwd.1 )
     158( cd $PKG1/usr/man/man3 ; mv rand.3 ssl_rand.3 )
     159( cd $PKG1/usr/man/man3 ; mv err.3 ssl_err.3 )
    200160# Compress and symlink the man pages:
    201161if [ -d $PKG1/usr/man ]; then
     
    213173fi
    214174
    215 # If there's an openssl1 directory, then build openssl-1.0 shared libraries for
     175# If there's an openssl0 directory, then build openssl-0 shared libraries for
    216176# compatibility with programs linked to those:
    217 if [ -d $CWD/openssl1 ]; then
    218   ( cd $CWD/openssl1
    219     ./openssl1.build || exit 1
     177if [ -d $CWD/openssl0 ]; then
     178  ( cd $CWD/openssl0
     179    ./openssl0.build || exit 1
    220180  ) || exit 1
    221181  # Don't put these in the openssl package...  openssl-solibs is enough.
    222182  #mkdir -p $PKG1/lib${LIBDIRSUFFIX}
    223   #cp -a $TMP/package-openssl1/usr/lib/lib*.so.?.?.? $PKG1/lib${LIBDIRSUFFIX}
     183  #cp -a $TMP/package-openssl0/usr/lib/lib*.so.?.?.? $PKG1/lib${LIBDIRSUFFIX}
    224184  #( cd $PKG1/lib${LIBDIRSUFFIX} ; ldconfig -l lib*.so.?.?.? )
    225185  mkdir -p $PKG2/lib${LIBDIRSUFFIX}
    226   cp -a $TMP/package-openssl1/usr/lib${LIBDIRSUFFIX}/lib*.so.?.?.? $PKG2/lib${LIBDIRSUFFIX}
     186  cp -a $TMP/package-openssl0/usr/lib/lib*.so.?.?.? $PKG2/lib${LIBDIRSUFFIX}
    227187  ( cd $PKG2/lib${LIBDIRSUFFIX} ; ldconfig -l lib*.so.?.?.? )
    228188fi
     
    244204mkdir -p $PKG2/usr/doc/openssl-$VERSION
    245205( cd $TMP/openssl-$VERSION
    246   cp -a ACKNOWLEDGEMENTS AUTHORS CHANGES* CONTRIBUTING FAQ INSTALL* \
    247   LICENSE* NEWS NOTES* README* $PKG2/usr/doc/openssl-$VERSION
     206  cp -a CHANGES CHANGES.SSLeay FAQ INSTALL INSTALL.MacOS INSTALL.VMS INSTALL.W32 \
     207  LICENSE NEWS README README.ENGINE $PKG2/usr/doc/openssl-$VERSION
    248208  # If there's a CHANGES file, installing at least part of the recent history
    249209  # is useful, but don't let it get totally out of control:
Note: See TracChangeset for help on using the changeset viewer.