Changeset 67ac101 for npl/fileserver/git/git.SlackBuild
- Timestamp:
- 03/05/19 11:53:48 (6 years ago)
- Branches:
- master
- Children:
- 551a8d2
- Parents:
- 12bffd8
- File:
-
- 1 edited
Legend:
- Unmodified
- Added
- Removed
-
npl/fileserver/git/git.SlackBuild
r12bffd8 r67ac101 1 1 #!/bin/bash 2 #Gebruik deze file als voorbeeld. Plaats de source tar.gz file in de zelfde directory als deze slackbuild3 #Met de NEED en DEP opties is het mogelijk om build dependencies aan te geven.4 #Voor de meeste packages hoeft er verder niks aan de variabellen veranderd te worden.5 ##################################### Build dependency info:6 7 2 #DEP:openssl 8 3 #DEP:zlib 9 4 #DEP:python 10 5 #DEP:curl 6 #DEP:expat 7 #NEED:linuxdoc_tools 11 8 12 #######Essential package info. 13 #Change these if autodetection fails. 14 15 #Name of the Syn-3 package that we are going to create 16 NAME=`basename $0|sed 's/.SlackBuild//'` 17 18 #Archive of the sourcefiles to unpack 19 SRC_ARC=`ls *.tar.*` 20 21 #Version of the sourcefiles 22 VER=`echo $SRC_ARC| sed 's/.*-//g' | sed 's/\.tar\..*$//g'` 23 24 #Directory of the sourcefiles to build (after optional unpacking) 25 SRC_DIR=`echo $SRC_ARC| sed 's/\.tar\..*$//g'` 26 27 #Architecture that the created binaries run on. 28 #Use noarch for scripts. 29 ARCH=`arch` 9 # 10 # Automaticly created by importpackage v1.0 11 # Imported from: https://mirrors.slackware.com/slackware/slackware-current/source/d/git/ 12 # Created at Mon Mar 4 16:54:55 CET 2019 30 13 31 14 32 ########Build and create the pacakge. 33 #Uncomment the stuff that you dont want or need 34 35 #Unpack source 36 #(uncomment if not needed) 37 syn3_unpack $SRC_ARC || exit 1 38 39 #apply patches 40 #patch -p1 -d $SRC_DIR < fluxkiosk.patch || exit 1 41 42 #build and install sourcefiles 43 #(use one of the other syn3_build_* scripts when needed) 44 export CONFIGURE_OPTS="" 45 export MAKE_OPTS="" 46 export NOTEST=1 47 pushd $SRC_DIR 48 make configure || exit 1 49 popd 50 syn3_build_automake $SRC_DIR /tmp/pkg || exit 1 51 52 #strip bins and other stuff 53 syn3_strip /tmp/pkg || exit 1 54 55 #move development stuff and create seperate development package 56 syn3_move_dev /tmp/pkg /tmp/pkgdev || exit 1 57 syn3_makepkg /tmp/pkgdev $NAME""_dev $VER $ARCH || exit 1 58 59 #make main package 60 syn3_makepkg /tmp/pkg $NAME $VER $ARCH || exit 1 15 ########### source original slackbuild (hopefully we dont need to modify it) 16 CWD=`pwd` 17 set -e 18 source ./git.SlackBuild.orig 61 19 62 20 21 ############ make syn3 packages 22 cd $CWD 23 for PKG in /tmp/package-*; do 24 NAME=`echo $PKG| sed 's/.*package-//'| sed 's/-/_/g'` 25 26 #seperate dev-package 27 syn3_move_dev $PKG $PKG""_dev 28 syn3_makepkg $PKG""_dev $NAME""_dev $VERSION $ARCH || exit 1 29 30 #make main package 31 syn3_makepkg $PKG $NAME $VERSION $ARCH || exit 1 32 done
Note: See TracChangeset
for help on using the changeset viewer.