- Timestamp:
- 01/18/22 12:49:32 (3 years ago)
- Branches:
- master
- Children:
- 9e573a2
- Parents:
- 929bb42 (diff), 4455cc2 (diff)
Note: this is a merge changeset, the changes displayed below correspond to the merge itself.
Use the(diff)
links above to see all the changes relative to each parent. - File:
-
- 1 edited
Legend:
- Unmodified
- Added
- Removed
-
npl/system/ca_certificates/ca-certificates.SlackBuild.orig
r929bb42 r892871d 1 #!/bin/ sh1 #!/bin/bash 2 2 3 3 # Slackware build script for ca-certificates 4 4 5 5 # Copyright 2009,2011 Robby Workman Northport, AL, USA 6 # Copyright 2012, 2013, 2015, 2016 Patrick J. Volkerding, Sebeka, MN, USA6 # Copyright 2012, 2013, 2015, 2016, 2018 Patrick J. Volkerding, Sebeka, MN, USA 7 7 # All rights reserved. 8 8 # … … 24 24 # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. 25 25 26 cd $(dirname $0) ; CWD=$(pwd) 27 26 28 PKGNAM=ca-certificates 27 VERSION=${VERSION:- 20161130}29 VERSION=${VERSION:-$(echo certdata-*.txt.xz | cut -f 2 -d - | cut -f 1 -d .)} 28 30 ARCH=noarch 29 31 BUILD=${BUILD:-1_slack14.2} 30 32 31 TARVERSION=${VERSION}+nmu1 33 # If the variable PRINT_PACKAGE_NAME is set, then this script will report what 34 # the name of the created package would be, and then exit. This information 35 # could be useful to other scripts. 36 if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then 37 echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz" 38 exit 0 39 fi 32 40 33 CWD=$(pwd) 41 TARVERSION=${VERSION} 42 34 43 TMP=${TMP:-/tmp} 35 44 PKG=$TMP/package-$PKGNAM … … 39 48 cd $TMP 40 49 41 # Need both $PKGNAM and $PKGNAM-$VERSION since upstream can't decide how 42 # to package their tarball: 43 rm -rf $PKGNAM $PKGNAM-$VERSION 50 rm -rf $PKGNAM 44 51 45 52 # Extract the tarball: 46 tar xvf $CWD/${PKGNAM} _$TARVERSION.tar.?z || exit 153 tar xvf $CWD/${PKGNAM}.tar.?z || exit 1 47 54 48 # Again, both $PKGNAM and $PKGNAM-$VERSION are needed here: 49 cd $PKGNAM-$VERSION || cd $PKGNAM || exit 1 55 cd $PKGNAM || exit 1 50 56 51 57 chown -R root:root . … … 56 62 -exec chmod 644 {} \; 57 63 58 # Obsolete?59 #zcat $CWD/patches/fixup_DESTDIR.diff.gz | patch -p1 || exit 164 # Remove incompatible command operators used to call 'run-parts': 65 zcat $CWD/fixup_update-ca-certificates.diff.gz | patch -p1 || exit 1 60 66 61 # Remove incompatible command operators used to call 'run-parts': 62 zcat $CWD/patches/fixup_update-ca-certificates.diff.gz | patch -p1 || exit 1 67 # Use "c_rehash" rather than "openssl rehash". They act mostly the same, but 68 # the openssl builtin is not available on older versions of Slackware, while 69 # c_rehash will always be there. 70 zcat $CWD/update-ca-certificates.c_rehash.diff.gz | patch -p1 || exit 1 71 72 # Update to certdata.txt from $CWD: 73 xzcat $CWD/certdata-${VERSION}.txt.xz > mozilla/certdata.txt 63 74 64 75 make || exit 1 65 76 make install DESTDIR=$PKG || exit 1 66 77 78 # Remove expired certificate: 79 if [ -r $PKG//usr/share/ca-certificates/mozilla/DST_Root_CA_X3.crt ]; then 80 rm -f $PKG//usr/share/ca-certificates/mozilla/DST_Root_CA_X3.crt 81 fi 82 67 83 mkdir -p $PKG/etc/ca-certificates/update.d 68 84 printf "# Automatically generated by $PKGNAM-$VERSION \n#\n" \ 69 > $PKG/etc/ca-certificates.conf .new85 > $PKG/etc/ca-certificates.conf 70 86 ( cd $PKG/usr/share/ca-certificates 71 87 find . -name '*.crt' | sort | cut -b3- 72 ) >> $PKG/etc/ca-certificates.conf .new88 ) >> $PKG/etc/ca-certificates.conf 73 89 74 90 mkdir -p $PKG/usr/man/man8 … … 77 93 78 94 mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION 79 mv debian/NEWS debian/NEWS.Debian 80 cp -a debian/NEWS.Debian debian/README.Debian $PKG/usr/doc/$PKGNAM-$VERSION 95 cp -a docs/* $PKG/usr/doc/$PKGNAM-$VERSION 81 96 82 97 mkdir -p $PKG/var/log/setup
Note: See TracChangeset
for help on using the changeset viewer.