Changeset e856512 for npl/overig/mozilla_nss/mozilla-nss.SlackBuild.orig
- Timestamp:
- 03/06/20 11:30:03 (5 years ago)
- Branches:
- master
- Children:
- eb67240
- Parents:
- efa4154
- File:
-
- 1 edited
Legend:
- Unmodified
- Added
- Removed
-
npl/overig/mozilla_nss/mozilla-nss.SlackBuild.orig
-
Property
mode
changed from
100755
to100644
refa4154 re856512 1 1 #!/bin/bash 2 2 # Copyright 2005, 2006, 2008, 2009, 2010, 2012 Eric Hameleers, Eindhoven, NL 3 # Copyright 2013, 2014, 2015, 2017, 2018 Patrick J. Volkerding, Sebeka, MN, USA3 # Copyright 2013, 2014, 2015, 2017, 2018, 2019 Patrick J. Volkerding, Sebeka, MN, USA 4 4 # All rights reserved. 5 5 # … … 27 27 PKGNAM=mozilla-nss 28 28 SRCNAM=nss 29 VERSION=${VERSION:-3. 46}30 NSPR=${NSPR:-4.2 2}29 VERSION=${VERSION:-3.50} 30 NSPR=${NSPR:-4.25} 31 31 BUILD=${BUILD:-1} 32 32 … … 90 90 find . \ 91 91 \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \ 92 -exec chmod 755 {} \ ;-o \92 -exec chmod 755 {} \+ -o \ 93 93 \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \ 94 -exec chmod 644 {} \ ;94 -exec chmod 644 {} \+ 95 95 96 96 echo Building ... … … 134 134 135 135 # Install nss-config: 136 sed -e "s,@prefix@,/usr,g" \137 -e "s,@MOD_MAJOR_VERSION@,$(printf $VERSION | cut -d. -f1),g" \138 -e "s,@MOD_MINOR_VERSION@,$(printf $VERSION | cut -d. -f2),g" \139 -e "s,@MOD_PATCH_VERSION@,$(printf $VERSION | cut -d. -f3),g" \140 $CWD/nss-config.in > $PKG/usr/bin/nss-config141 chmod 755 $PKG/usr/bin/nss-config136 #sed -e "s,@prefix@,/usr,g" \ 137 # -e "s,@MOD_MAJOR_VERSION@,$(printf $VERSION | cut -d. -f1),g" \ 138 # -e "s,@MOD_MINOR_VERSION@,$(printf $VERSION | cut -d. -f2),g" \ 139 # -e "s,@MOD_PATCH_VERSION@,$(printf $VERSION | cut -d. -f3),g" \ 140 # $CWD/nss-config.in > $PKG/usr/bin/nss-config 141 #chmod 755 $PKG/usr/bin/nss-config 142 142 143 143 # Provide pkg-config files: … … 175 175 176 176 # Add documentation: 177 mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION178 cp -a \179 $CWD/MPL-1.1.txt $CWD/gpl-2.0.txt $CWD/lgpl-2.1.txt \180 $CWD/faq.html \181 $PKG/usr/doc/$PKGNAM-$VERSION182 chown -R root:root $PKG/usr/doc/$PKGNAM-$VERSION177 #mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION 178 #cp -a \ 179 # $CWD/MPL-1.1.txt $CWD/gpl-2.0.txt $CWD/lgpl-2.1.txt \ 180 # $CWD/faq.html \ 181 # $PKG/usr/doc/$PKGNAM-$VERSION 182 #chown -R root:root $PKG/usr/doc/$PKGNAM-$VERSION 183 183 184 184 # Strip binaries: -
Property
mode
changed from
Note: See TracChangeset
for help on using the changeset viewer.