Ignore:
Timestamp:
03/06/20 11:30:03 (5 years ago)
Author:
Edwin Eefting <edwin@datux.nl>
Branches:
master
Children:
eb67240
Parents:
efa4154
Message:

upgrade to libreswan 3.31 and mozilla nss 3.50

File:
1 edited

Legend:

Unmodified
Added
Removed
  • npl/overig/mozilla_nss/mozilla-nss.SlackBuild.orig

    • Property mode changed from 100755 to 100644
    refa4154 re856512  
    11#!/bin/bash
    22# Copyright 2005, 2006, 2008, 2009, 2010, 2012  Eric Hameleers, Eindhoven, NL
    3 # Copyright 2013, 2014, 2015, 2017, 2018  Patrick J. Volkerding, Sebeka, MN, USA
     3# Copyright 2013, 2014, 2015, 2017, 2018, 2019  Patrick J. Volkerding, Sebeka, MN, USA
    44# All rights reserved.
    55#
     
    2727PKGNAM=mozilla-nss
    2828SRCNAM=nss
    29 VERSION=${VERSION:-3.46}
    30 NSPR=${NSPR:-4.22}
     29VERSION=${VERSION:-3.50}
     30NSPR=${NSPR:-4.25}
    3131BUILD=${BUILD:-1}
    3232
     
    9090find . \
    9191  \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
    92   -exec chmod 755 {} \; -o \
     92  -exec chmod 755 {} \+ -o \
    9393  \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
    94   -exec chmod 644 {} \;
     94  -exec chmod 644 {} \+
    9595
    9696echo Building ...
     
    134134
    135135# Install nss-config:
    136 sed -e "s,@prefix@,/usr,g" \
    137     -e "s,@MOD_MAJOR_VERSION@,$(printf $VERSION | cut -d. -f1),g" \
    138     -e "s,@MOD_MINOR_VERSION@,$(printf $VERSION | cut -d. -f2),g" \
    139     -e "s,@MOD_PATCH_VERSION@,$(printf $VERSION | cut -d. -f3),g" \
    140     $CWD/nss-config.in > $PKG/usr/bin/nss-config
    141 chmod 755 $PKG/usr/bin/nss-config
     136#sed -e "s,@prefix@,/usr,g" \
     137#    -e "s,@MOD_MAJOR_VERSION@,$(printf $VERSION | cut -d. -f1),g" \
     138#    -e "s,@MOD_MINOR_VERSION@,$(printf $VERSION | cut -d. -f2),g" \
     139#    -e "s,@MOD_PATCH_VERSION@,$(printf $VERSION | cut -d. -f3),g" \
     140#    $CWD/nss-config.in > $PKG/usr/bin/nss-config
     141#chmod 755 $PKG/usr/bin/nss-config
    142142
    143143# Provide pkg-config files:
     
    175175
    176176# Add documentation:
    177 mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
    178 cp -a \
    179   $CWD/MPL-1.1.txt $CWD/gpl-2.0.txt $CWD/lgpl-2.1.txt \
    180   $CWD/faq.html \
    181   $PKG/usr/doc/$PKGNAM-$VERSION
    182 chown -R root:root $PKG/usr/doc/$PKGNAM-$VERSION
     177#mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
     178#cp -a \
     179#  $CWD/MPL-1.1.txt $CWD/gpl-2.0.txt $CWD/lgpl-2.1.txt \
     180#  $CWD/faq.html \
     181#  $PKG/usr/doc/$PKGNAM-$VERSION
     182#chown -R root:root $PKG/usr/doc/$PKGNAM-$VERSION
    183183
    184184# Strip binaries:
Note: See TracChangeset for help on using the changeset viewer.